Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A couple of weeks ago I was tweaking the running services in my Vista installation and now can't change my desktop background or view any pictures as large icons. In extra large they display fine, which makes me think my machine is stuck in some sort of reduced functionality mode.

I've tried reinstalling my graphics drivers, clearing out my icon cache, reassociating images, and resetting all services to their defaults but nothing has sorted it out. Unfortunately I don't have a system restore old enough to go back to.

Any ideas guys?

UPDATE: I just found I can change the backdrop to BMPs but not JPGs. A quick Google popped up a couple of things, but I haven't had time to properly investigate.

share|improve this question
A word of advice: please, whatever you do, don't mess around with Windows services. That's one of the easiest ways of breaking something without even noticing; closing them has a lot of side effects that are easily missed. – alex Oct 7 '09 at 10:31

Use this webapp to restore your Windows services to their default. That should hopefully fix things.

Edit: seeing how this didn't work, I'll suggest something else. Try creating a new user account on the machine. See if the behavior is still there; this should at least help you troubleshoot your problem a bit.

share|improve this answer
That webapp is staying in my favorites – admintech Oct 7 '09 at 10:36
Mine too. that's why I answered so fast :) – alex Oct 7 '09 at 10:46
Unfortunately, that the first thing I did to try and get things back to normal. Great webapp thanks, but didn't help this time. – Damien Ryan Oct 7 '09 at 10:49
Sorry it didn't help. Maybe there's a larger underlying problem here if the services are not responsible. – alex Oct 7 '09 at 10:54
Thanks for plugging away :) Tried a new user account and that had the same problem. I thought it might have been malware or a GPO, but neither was present. – Damien Ryan Oct 9 '09 at 10:43
up vote 0 down vote accepted

Not sure of the root cause of the problem, but the ComboFix utility here sorted everything out.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .