Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Can someone explain why I cannot find files with certain file extensions? The repro steps are below.

  1. Create Folder.
  2. Create TXT file with the following text. <root />
  3. Use Windows Explorer to search the folder for files that contain the word root.
  4. The file that was just created will show up.
  5. Change the extension of that file to XML.
  6. Perform the search again but the file doesn't show up.
share|improve this question
    
Your question implies that the file extension matters to the problem but your example shows that it doesn't. –  mikebabcock Dec 19 '12 at 19:51
    
mikebabcock, I don't understand your comment. Windows Explorer is telling me that there are no files in the folder that contain the word root which of course if not true. The only difference is the file extension. –  Mike Dec 19 '12 at 19:55
    
Ah your sentence in #4 said "the file should show up" I took to mean "didn't but should" and you meant "does show up" –  mikebabcock Dec 19 '12 at 19:57
    
As an experiment, try editing the file to contain valid XML and search both tag and content to see if Windows is ignoring tag names (like in your example). So if you put <name>bill</name> in an .xml file does 'bill' give you a hit but not 'name'? –  mikebabcock Dec 19 '12 at 19:58
    
mikebabcock, I just tried that and it didn't make a difference. –  Mike Dec 19 '12 at 20:01

2 Answers 2

up vote 3 down vote accepted

Method 2 of this KB article explains how to enable searching files of unknown type: http://support.microsoft.com/default.aspx?scid=KB;EN-US;309173

To configure Windows XP to search all files no matter what the file type, obtain the latest service pack for Windows XP and then turn on the Index file types with unknown extensions option.

If you use this method, Windows XP searches all file types for the text that you specify. This can affect the performance of the search functionality. To do this:

  1. Click Start, and then click Search (or point to Search, and then click For Files or Folders).
  2. Click Change preferences, and then click With Indexing Service (for faster local searches).
    • This particular step is optional; personally, I don't enable this setting.
  3. Click Change Indexing Service Settings (Advanced). Note that you do not have to turn on the Index service.
  4. On the toolbar, click Show/Hide Console Tree.
  5. In the left pane, right-click Indexing Service on Local Machine, and then click Properties.
  6. On the Generation tab, click to select the Index files with unknown extensions check box, and then click OK.
  7. Close the Indexing Service console.
share|improve this answer
    
That works! Thanks –  Mike Dec 19 '12 at 20:18

Explorer seems to filter certain file types out of its index. There claims to be a solution with a registry hack but it didn't work for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.