Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am dual-booting Windows 8 and Ubuntu 12.04. My partition scheme looks like this:

/dev/sda1 - Windows 8 (nfts)
/dev/sda2 - Ubuntu / (ext4)
/dev/sda3 - Ubuntu home (ext4)
/dev/sda5 - swap
/dev/sda6 - Shared data partition (exfat)

(First off, yes I do have exfat libraries installed on Ubuntu)

I created some PNG images in Windows and saved them on my shared partition. From Ubuntu, I edited the images in GIMP and saved them (replacing the ones on the shared partition).

When I boot into Windows, the files appear unchanged - exactly like they did before I edited them from Ubuntu. I even added a folder and deleted some other files, but none of these changes exist in Windows.

When I boot into Ubuntu, all of the changes are still there.

It is as if Windows is caching the old file structure...

How is this possible? Thanks in advance.

Edit -- commands output

~~ lsblk

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0 165.1G  0 part 
├─sda2   8:2    0  21.3G  0 part /
├─sda3   8:3    0  98.9G  0 part /home
├─sda4   8:4    0     1K  0 part 
├─sda5   8:5    0   7.8G  0 part [SWAP]
└─sda6   8:6    0 172.7G  0 part /mnt/shared_data

~~ /etc/fstab

# <file system>                 <mount point>       <type>  <options>           <dump>  <pass>
proc                        /proc           proc    nodev,noexec,nosuid 0       0

# /dev/sda2
UUID=8f700f65-b5c7-4afc-a6fb-8f9271e0fb5e   /           ext4    errors=remount-ro   0       1

# /dev/sda3
UUID=f0d688b7-22bd-4fa7-bc1b-a594af2933fa       /home               ext4    defaults        0       2

# /dev/sda5
UUID=3bc2399b-5deb-4f04-924b-d4fc77491997   none            swap    sw          0       0

# /dev/sda6
UUID=F2DE-BC47                  /mnt/shared_data    exfat   defaults        0   3

~~ /etc/mtab

/dev/sda2 / ext4 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
udev /dev devtmpfs rw,mode=0755 0 0
devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
tmpfs /run tmpfs rw,noexec,nosuid,size=10%,mode=0755 0 0
none /run/lock tmpfs rw,noexec,nosuid,nodev,size=5242880 0 0
none /run/shm tmpfs rw,nosuid,nodev 0 0
/dev/sda3 /home ext4 rw 0 0

/dev/sda6 /mnt/shared_data fuseblk rw,nosuid,nodev,allow_other,blksize=4096 0 0

binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/matt/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=matt 0 0
share|improve this question
    
Can you please post the output of the commands "lsblk", "cat /etc/fstab" and "cat /etc/mtab"! –  FSMaxB Dec 19 '12 at 20:57
    
In /etc/fstab I changed the mount options from 'defaults' to 'rw' and that fixed it. I don't know very much about the fstab file though, is this a permanent fix or was it just coincidence? –  Matt Robertson Dec 19 '12 at 22:12
add comment

1 Answer

up vote 0 down vote accepted

I'm going to go ahead and mark this as solved. Changing the mount options from defaults to rw worked.

From the Linux help files:

sync and async

How the input and output to the filesystem should be done. sync means it's done synchronously. If you look at the example fstab, you'll notice that this is the option used with the floppy. In plain English, this means that when you, for example, copy a file to the floppy, the changes are physically written to the floppy at the same time you issue the copy command.

However, if you have the async option in /etc/fstab, input and output is done asynchronously. Now when you copy a file to the floppy, the changes may be physically written to it long time after issuing the command. This isn't bad, and may sometimes be favorable, but can cause some nasty accidents: if you just remove the floppy without unmounting it first, the copied file may not physically exist on the floppy yet!

async is the default. However, it may be wise to use sync with the floppy, especially if you're used to the way it's done in Windows and have a tendency to remove floppies before unmounting them first.

The defaults mount option includes the async option. I assume this is what was causing the problem, but I'm still not sure. If anyone knows why, please comment.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.