Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am on a Mac. I want to install vim plugins. The problem like always is that after following exactly the instructions on https://github.com/tpope/vim-pathogen the plugin fugitive will not load. I followed this also https://github.com/scrooloose/nerdtree again nothing. Could somebody explain me why is this happening and a way to fix it please?

This is my structure:

$ls .vim/*
.vim/autoload:
fuf          fuf.vim      l9           l9.vim       pathogen.vim rails.vim

.vim/bundle:
vim-fugitive

.vim/doc:
fuf.jax   fuf.txt   l9.jax    l9.txt    rails.txt tags      tags-ja

.vim/plugin:
fuf.vim   l9.vim    rails.vim

invoking pathogen

  call pathogen#infect()
  filetype off
  syntax on
  filetype plugin indent on

added from Pathogen does not load plugins

:scriptnames output

  1: /usr/share/vim/vimrc
  2: /Users/test/.vimrc
  3: /usr/share/vim/vim73/syntax/syntax.vim
  4: /usr/share/vim/vim73/syntax/synload.vim
  5: /usr/share/vim/vim73/syntax/syncolor.vim
  6: /usr/share/vim/vim73/filetype.vim
  7: /usr/share/vim/vim73/ftplugin.vim
  8: /usr/share/vim/vim73/indent.vim
  9: /usr/share/vim/vim73/macros/matchit.vim
 10: /Users/test/.vim/autoload/pathogen.vim
 11: /usr/share/vim/vim73/ftoff.vim
 12: /usr/share/vim/vim73/syntax/nosyntax.vim
 13: /Users/test/.vim/plugin/fuf.vim
 14: /Users/test/.vim/autoload/l9.vim
 15: /Users/test/.vim/autoload/fuf.vim
 16: /Users/test/.vim/autoload/fuf/buffer.vim
 17: /Users/test/.vim/autoload/fuf/file.vim
 18: /Users/test/.vim/autoload/fuf/coveragefile.vim
share|improve this question

migrated from stackoverflow.com Dec 19 '12 at 20:45

This question came from our site for professional and enthusiast programmers.

    
What is the output of :scriptnames? –  Wayne Werner Dec 19 '12 at 12:07
    
updated the answer –  Test Test Dec 19 '12 at 12:10
1  
@ADC - Vim questions belong on SO –  Lieven Keersmaekers Dec 19 '12 at 13:26
    
You should create an issue on pathogen's page. Tim Pope is very reactive. Also, filetype off should be above call pathogen#infect(). –  romainl Dec 19 '12 at 19:51

2 Answers 2

Without looking at your complete .vimrc I would adventure to say that you should set the flag for non-vi compatibility: set nocompatible

That should be the first thing (or one of the first things) in your .vimrc

The Vim version that comes with OSX is not only a bit behind but it is also not compiled with a bunch of features plugins require. Some plugins don't even load at all if the version is not compatible with the ones they support.

Finally, I would start Vim with the verbose flag on (vim -V) where you can see all the output of what exactly Vim is loading and looking for.

This answer is somewhat vague, but there are just too many things that can happen to get that behavior. I just mentioned the top 3 on my list: latest Vim version compiled with huge flag, set nocompatible in your .vimrc and load Vim with the verbose flag.

share|improve this answer
    
The existence of a .vimrc already implies :set nocompatible. –  Ingo Karkat Dec 20 '12 at 0:21
    
The esxistence of .vimrc doesn't imply anything. What makes you think someone can't have a compatible flag in there? –  alfredodeza Dec 20 '12 at 21:04
    
See :help compatible-default. It doesn't hurt, but it's not necessary to include. –  Ingo Karkat Dec 21 '12 at 0:23

I know this isn't really the answer for your problem, but did you tried Vundle? It is another very good Vim's plugin manager, I also switched from Pathogen to Vundle after some problems.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.