Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Ubuntu 12.04 I got an error message saying:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 

After I ran that command, nothing happened and the same error message appeared when I tried again.

share|improve this question

2 Answers 2

Probably some package's configure script had a problem. When you run sudo dpkg --configure -a you probably see a bunch of output on the screen; I highly doubt that it "just" fails. Without seeing the entire output of what the error message is, it's hard to know what the problem is. The reason for package manager failure could be almost anything, from bad disk blocks, to incomplete downloads of DEB files, to programming errors in the package upgrade/install scripts, etc.

share|improve this answer

just see the issue fixed flow

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

pd@admin:~$ sudo dpkg --configure -a
dpkg: error: parsing file '/var/lib/dpkg/updates/0024' near line 0: newline in field name `#padding'

pd@admin:~$ sudo rm /var/lib/dpkg/updates/0024

pd@admin:~$ sudo dpkg --configure -a

pd@admin:~$ sudo apt-get install appname_mention_here

Reading package lists... Done Building dependency tree
Reading state information... Done

Now its working the installation....!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.