Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed win7 on virtual box with network configuration as bridged adapter. My host machine is macbook Air with OS X 10.8.2.

This is the host's TCP/IP configuration: this is the host's TCP/IP configuration enter image description here

This is network connection details of my virtual machine: This is network connection details of my virtual machine

I can ping any computer on my LAN from vbox. Also I can ping vbox from any computer on my LAN. But my vbox does not have Internet access. When I switch to NAT in vbox's network settings the internet access appears. I wonder, why vbox doesn't have Internet access while configured as bridged adapter. Also, everything works on my friend's wifi LAN. I wonder, why it doesn't work in my house. Any suggestions?

share|improve this question

migrated from stackoverflow.com Dec 20 '12 at 6:34

This question came from our site for professional and enthusiast programmers.

    
Sounds like there is nothing wrong in your Virtualbox settings (because you can get to the LAN machines), but your gateway or firewall is blocking the virtual machine traffic. –  Edu Dec 16 '12 at 21:36
    
im using xfinity router. couldn't find in its settings anything that might block my vbox. however, when i set my vbox as DMZ it works fine –  tesla Dec 16 '12 at 23:41
    
Is there any specific reason for preferring bridged adapter over NAT? –  anishsane Dec 18 '12 at 14:08
    
Bridging a Wi-Fi adapter is problematic to say the least - there are lots of questions on the various Stack Exchange sites that go over (and over, and over) this. Do you have a wired ethernet connection available? If not, a NAT connection type for your guest and port forwarding will be the next best choice: serverfault.com/questions/421719/… –  Goyuix Dec 18 '12 at 22:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.