Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have set up Ruby on Rails on Ubuntu into a VirtualBox instance on my PC, I enabled Samba and I'm connecting to it via the home network from my Mac. All is fine except that I have some issues deleting some files from inside applications e.g. in Sublime Text 2 when I right click a file in the browser and select delete nothing happens (same in my Git client). To be able to delete files I have to navigate to the folder in Finder (which leaves those nasty .DS_Store files scattered all around) or issue the delete command from the terminal (inconvenient). If you're asking why I'm using VirtualBox for Rails instead of doing the development directly on the Mac it's because the ease of portability.

So my question is: are there any network sharing options which I could use to make the Linux instance play nicer with my Mac?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

If you're ready to play with the terminal, you might want to use rsync with ssh on the linux guest to sync your files. I should be called with something like `rsync --delete ~/Documents/RailsSite/ ubuntu:/var/www/RailsSite/ But I understand you don't want to use to much of the cli.

If it's only the .DS_Store files that bothers you when using the Finder to delete files, you might want to check that other Question that has a nice tool, Blue Harvest, to disable creating those files on network drives.

But the deletion issue you're seeing are probably related to incorrect permissions on your shared folder. You might want to check if you can relax those a bit, maybe by putting the shared root directory and all sub directories in 777 mode (if it's not making a security issue, I mean if your gest Ubuntu is not open to the world). This could be as easy as a one time command chmod -R 777 /home/user/RailsSite/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.