Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a complete networking beginner, trying to install OpenWRT on a TPLink 703N, following these instructions : http://wiki.xinchejian.com/wiki/Install_OpenWRT_on_TPlink_WR703N

Having installed and OpenWRT and configured it as outlined on that page, we're trying to see the internet from it (in order to run opkg etc). We have the TPLink connected to our router/modem via ethernet cable and can ssh to it from the other machines on the same network.

However we can't a) see the TPLink itself as a wifi router. (Doesn't look like wifi is currently enabled) b) see the internet from inside it (to run opkg etc.)

Can anyone give some clues (in fairly layman's language) of how to debug this? What kind of problems should we look for? And how should we resolve them?

/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option ifname 'wlan0'
    option proto 'dhcp'

/etc/config/wireless

config wifi-device  radio0
    option type     mac80211
    option channel  11
    option hwmode   11ng
    option path 'platform/ar933x_wmac'
    option htmode   HT20
    list ht_capab   SHORT-GI-20
    list ht_capab   SHORT-GI-40
    list ht_capab   RX-STBC1
    list ht_capab   DSSS_CCK-40
    # REMOVE THIS LINE TO ENABLE WIFI:
    #option disabled 1

config wifi-iface
    option device   radio0
    #option network  lan
    option network  wan
    #option mode     ap
    option mode     sta
    option ssid     'THE NAME OF OUR EXISTING WIFI NETWORK'
    #option encryption none
    option encryption wep+shared
    option key 'WEP PASSWORD FOR OUR EXISTING WIFI NETWORK'

cheers

phil

share|improve this question

migrated from serverfault.com Dec 20 '12 at 16:09

This question came from our site for professional system and network administrators.

    
Show enabled network interfaces with ip link and see your wifi settings with iwconfig wlan0 or iw -i wlan0 status. For debugging purpose there are logs in cat /var/log/messages | more and cat /var/log/syslog | more (not sure if this one is in openwrt) –  week Dec 20 '12 at 16:45

1 Answer 1

For your wireless issues, if we look at your wireless configuration:

config wifi-iface
    option device   radio0
    #option network  lan
    option network  wan
    #option mode     ap
    option mode     sta
    option ssid     'THE NAME OF OUR EXISTING WIFI NETWORK'
    #option encryption none
    option encryption wep+shared
    option key 'WEP PASSWORD FOR OUR EXISTING WIFI NETWORK'

You have the mode ap line commented out and replaced with the sta option. According to the OpenWRT documentation, this means that the wireless interface is configured for client mode. With the other options you have in place, your device is configured to act as a client device and connect to your existing network. Because if this, it can't function as an access point.

If you're device is connecting to your network via the wireless interface, why do you have a Ethernet cable connected to your LAN?

I do not see where you note your DNS servers. This might be the cause of why the device can't 'access' the internet to get packages from opkg. You may check to see what the content of /etc/resolv.conf is, since it lists what name servers the device uses for DNS name resolution.

An example (using Google's name servers):

nameserver 8.8.8.8
nameserver 4.4.4.4

You can also try adding the following to /etc/config/network:

option dns 8.8.8.8

Hope this helps...

EDIT

Here is a suggested configuration for the wifi interface for using it as an access point:

config wifi-iface
    option device     radio0
    option network    lan
    option mode       ap
    option ssid       'DESIRED SSID HERE'
    option encryption wep+shared
    option key        'YOUR WEP PASSWORD FOR ACCESS'

You want network set to lan and mode set to ap. I highly recommend some form of encryption and would suggest you use something other than WEP because it's insecure.

share|improve this answer
    
Thanks. The DNS tip got us on to the internet so we could download opkg and the browser-UI which let us set up the rest of the parameters. Unfortunately, although we can now see the router via wifi, it still doesn't seem to let us connect to it with wifi. –  interstar Dec 21 '12 at 18:36
    
currently : config wifi-device 'radio0' option type 'mac80211' option channel '11' option hwmode '11ng' option path 'platform/ar933x_wmac' option htmode 'HT20' list ht_capab 'SHORT-GI-20' list ht_capab 'SHORT-GI-40' list ht_capab 'RX-STBC1' list ht_capab 'DSSS_CCK-40' option txpower '27' option country 'GB' config wifi-iface option device 'radio0' option key 'KEY' option ssid 'NETWORK' option network 'wan' option encryption 'none' option mode 'ap' –  interstar Dec 21 '12 at 18:37
    
Anything in the above list look strange? –  interstar Dec 21 '12 at 18:40
    
@interstar See updated answer. –  Justin Pearce Dec 21 '12 at 19:43
    
Many thanks Justin. Will try this shortly. –  interstar Dec 21 '12 at 20:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.