Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got this message when I tried to login to my own dedi or one of the cpanel.

The security certificate presented by this website was issued for a different website's address.

It's my site. I trusted it. How do I get rid that message?

share|improve this question

migrated from webmasters.stackexchange.com Dec 20 '12 at 16:34

This question came from our site for pro webmasters.

    
What browser are you using? –  Jack Lockyer Dec 20 '12 at 15:53
    
internet explorer. –  Jim Thio Dec 20 '12 at 16:25
    
"my own dedi" - is this a dedicated server?! If so then you should resolve the cert issue. If it's a shared server then it's common to share a cert across all sites, in which case you can access the generic domain the site is intended for. –  w3d Dec 20 '12 at 16:57
    
What is the address in the certificate and what is the address of the site you are trying to connect to (replace your domain name with example.com) –  Scott Chamberlain Dec 20 '12 at 17:00

2 Answers 2

up vote 2 down vote accepted

If you go to Tools -> Internet Options, Advanced tab, and scroll to the bottom, you'll find an option to "Warn about certificate address mismatch", which you can disable; the change will take effect after you restart IE, and should stop the browser from complaining about the cert.

Unfortunately, it'll also stop the browser from complaining about address mismatches on every other site you visit, as well. That's less than ideal, but it's the kind of tradeoff you get to make when you use IE.

Of course, installing a cert with the right address on it (or, if it's a subdomain you're visiting and the cert's issued for a higher-level domain, a wildcard cert) would be the right answer, but if you can't do that, this will at least suppress the warning.

share|improve this answer
    
The certificate is for the main domain in the server. I tried to access cpanel on another domain under that main domain. –  Jim Thio Dec 21 '12 at 3:09
1  
"That's less than ideal" - bit of an understatement. This is a serious security vulnerability and is not recommended. –  w3d Dec 21 '12 at 12:13

You should install the site's certificate into your local certificate store so your browser will then trust it.

I use self-signed SSL certs on development servers, so in each of my browsers I install the servers' certs. This also works for expired or mismatched "real" certificates.

Here's a link to do this in IE: http://www.poweradmin.com/help/sslhints/ie.aspx

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.