Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm toying around with setting up port forwarding on my home router. I couldn't get it to work, though. Here is what I tried:

When I opened my router's public IP address in my browser, it pulled up the MikroTik RouterOS page. Then I opened up 192.168.1.1 in my browser, logged in, and set port 80 to be forwarded to my computer at 192.168.xxx.xxx, where Apache is running. After this, when I opened the public IP again, I got the same RouterOS page. (I have a TP-Link wireless router.)

I also tried forwarding port 8080, and I started Apache connected to port 8080, but when I tried viewing it in the browser, I got a 'could not connect' error.

I checked the port with an online tool, and it doesn't seem to be blocked.

It seems like port forwarding doesn't do anything. It's almost as if the browser is getting a connection to the wrong router, though that seems impossible.

What could be causing this?

share|improve this question
    
I know the pain of not knowing what is going on. I've been there and i am pretty sure you did not rebooted the router after making changes. Do it please and let me know if my answer is correct. Am i right about reboot? Use the power switch. – mnmnc Dec 20 '12 at 19:38
    
@mnmnc I rebooted from the control panel, but that didn't fix it. – Kendall Frey Dec 20 '12 at 19:49
    
Do you have two routers? Can you "tracert 8.8.8.8" and show us the results. We only need the first 3 hops. – NitroxDM Dec 20 '12 at 21:36
    
@NitroxDM The first IP is 192.168.1.1. When I browse to the second IP, I get the same result as opening my public IP (the RouterOS page). The third IP is also very similar to my public IP. Does this mean my router is in a sub-network controlled by a router at the ISP? – Kendall Frey Dec 20 '12 at 23:42
    
sub-network - yes but that isn't your issue. How are your MikroTik and TP-Link connected? And where is the server connected? – NitroxDM Jan 8 '13 at 15:45

With your current ISP's set up you can't. Call them and ask for a static IP. If they will give you that you might be in business.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .