Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There is a desktop computer on my network that is giving me headaches right now. I have a fiber/LAN broadband access with a dedicated LAN port outlet in the wall. From there I have a Ethernet cable running to a 5-port switch, and then another cable running from the switch to a wireless router. The computer in question is connected to the router, with a Ethernet cable.

The problem is that I get local access to the router, but not to the Internet or the WAN side of the router. So the computer is getting an IP address from the router, which is specially reserved IP for this particular computer. I have it on the reservation list. So I know it is getting the proper IP address.

I also have MAC filtering enabled on the router enabled that allows access only from specified computers. Naturally, I have specified the MAC address of this particular computer in the list. I was looking at this just now, thinking... you know... maybe it's because I have MAC filtering enabled. But that looks fine, and I even tried disabling MAC filtering and it didn't help my case.

Now here's where it becomes really weird! I can access the web interface of the router from that same computer, and then log on to it and choose to reboot it. After the router has rebooted, not only do I have local access, I suddenly even have Internet access and I can start exploring the web! But then after a few minutes it goes downhill again. I can be surfing the web and then suddenly pages stop to load and I get timeout errors.

At the same time, the router provides Internet access on two other computers just fine! But these other two are wireless though.

What could this be? What should I look at? How can I rule out the router as the source of the problem?

I have had the problem where Internet access dies and then comes back again, but this was months ago, and it was on one of the wireless computers, and this is no issue no more. But this current situation is not like that, in this case the Internet access just dies and never comes back again, unless I reboot the router.

So far I have checked all the settings, I have obviously rebooted the router several times, and I have rebooted the computer, and I tried disabling MAC filtering and re-enabling it, I tried connecting to a different LAN port on the router, etc. What do I do next? Get a new router? Get a new computer? Ones witch will not work either?

I don't get this, the problem started today, everything worked fine for months. There were some technical issues with my ISP because I couldn't get out on the web. I was browsing the web when sites stopped responding. At that time I couldn't get any of the computers or the smartphones to get out on the web over the wifi. I tried everything and then finally reported the problem and ISP said they would investigate the case and call me back.

They told me to connect the desktop computer directly to the wall outlet (in order to bypass the router and all the rest) and ping their DNS, and so I did and I got only timeout errors, so it didn't respond. This is the very same computer that I am having problems with now.

They haven't called me yet, but when I came back home the problem seemed to be resolved because I could browse the web again. And I got response when I pinged the DNS address again. But it only worked on the wireless computers, not the wired desktop computer.

So I have Internet access again. But only on two of the computers? Not all three? Makes no sense!! I have not made any changes actually in the settings, not in the computer nor in the router. And I have wired the Ethernet cables back to to the way they were before.

share|improve this question
1  
I had a similar issue with a dlink wireless router. I suspect your router is dying. Do you have another router you can test with? You could then rule the computer out as a possible cause. –  Pete Dec 20 '12 at 19:44
    
Have you tried putting the router in front of the switch? fiber>router>switch instead of fibre>switch>router –  BroScience Dec 20 '12 at 20:00
    
I can't even begin to talk about all the issues I have had with D-Link routers over the past years, and especially with this one in particular. This is the DIR-825, a lighter version of the top end model DIR-855. But I have exchanged it two times, this is the third one I got on warranty, this one came straight from D-Link Europe headquarters (D-Link House in London). It has worked for several months now with no issues, if any the issues have been on the ISP side and not the router. D-Link has worked out some of the bugs in the firmware. But boy do they suck! –  sammyg Dec 20 '12 at 20:02
    
The routers are fine, hardware-wise, but they really suck big time in firmware. That's kind of the Achilles heel of D-Link routers. Unfortunately I don't have a spare router to try out. Any way to tell if it's smoked? I could do a complete reset and re-flash it but I will leave that as last resort for now. –  sammyg Dec 20 '12 at 20:05
    
@BroScience I have to have the switch in front of the router. This is because I have an ATA (analog telephony adapter). It's a device I use for my VoIP phone service. It allows me to use regular (analog or digital) phone with regular RJ-11 phone connector. And it is issued by my provider so I can't get a DECT residential phone with VoIP, the phone number is somehow embedded in the ATA box. –  sammyg Dec 20 '12 at 20:11

1 Answer 1

To verify the pc is not at fault, I suggest replacing the router. I never have had any luck with Dlink so I would suggest a different brand also. If the new router has the same issue then we know it is not the router. I doubt that tho, I think you will find that a different router fixes it.

share|improve this answer
    
This is a little bit old issue now. But I can tell you that I have kept the router and I'm still using it today. Actually, hardware-wise the DIR-825 is a pretty good router, it has the same basic hardware as the ever so popular Netgear WNDR3700 which received very good reviews when it came out. They were both released the same year. But the problem with all D-Link routers is that their firmware STINKS! It has been proven so many times now, D-Link is incompetent, they don't know how to write a proper firmware for their routers! –  sammyg Jul 6 '13 at 17:41
    
I have tried several different firmware versions, all the versions out there, available for DIR-825. I even got some Beta versions from D-Link not yet released. Beta or not, none of them seemed to solve any of the many problems I had with this router (NAT and VoIP communication among other things). What I have done is I have replaced the stock firmware with open source DD-WRT firmware. Thankfully this router is supported thanks to the Atheros chipset. Ever since I switched to DD-WRT about a year ago I have been at peace at last. I have not ever had a need to reboot the router. –  sammyg Jul 6 '13 at 17:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.