Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have checked off "Allow Remote Assistance Connections to this Computer" and "Allow Connections from Computers Running Any Version of Remote Desktop." Additionally, I've configured my linksys router to forward (Both TCP and UDP) port 3389 to my computer's local ip address.

However, when I'm trying to use remote desktop to connect to my computer (I typed in the external IP address, of course), I still got the typical error: " Remote Desktop can't connect to the remote computer for one of these reasons 1) Remote access to the server is not enabled 2) The remote computer is turned off 3) The remote computer is not available on the network Make sure the remote computer is turned on and connected to the network, and that remote access is enabled. "

Edit: I've tried both accessing my external IP from outside my network and try to use my external IP from within my network, neither method worked. I also tried connecting by using another computer in the network through the Local IP address, and it did not work...

share|improve this question
    
You don't need UDP, though that won't stop it working. Does your router have the facility to log inbound connections? –  Paul Dec 20 '12 at 22:16

2 Answers 2

up vote 3 down vote accepted
  1. Scan your external IP address with nmap/zenmap. and check if you will see port 3389 listed as open
  2. Try using telnet telnet external_ip 3389 and check netstat -a -n to see if the connection does not hang in SYN_SENT state.
  3. Question: Did you rebooted the router after creating a port forwarding?
  4. Are you accessing the external IP from outside of your network or do you try to use your external IP from within your net? It is not clear from what you described.

Important: Please also check if your firewall blocks port 3389.

share|improve this answer
    
1) i used canyouseeme.org to check my port 3389, and it says the port is not open. 2) havn't try this yet 3) I did not reboot the router after creating port forwarding 4) I've tried both accessing my external IP from outside my network and try to use my external IP from within my network, neither method worked. –  Hking Dev Dec 21 '12 at 3:12
    
and I just tried to control the computer with another computer in the network using the network IP address, still can't connect... –  Hking Dev Dec 21 '12 at 3:16
    
problem solved. must disable Kaspersky firewall. –  Hking Dev Dec 21 '12 at 3:38

Another thing to try would be to connect to your computer via remote desktop from another computer on your LAN. Are you able to connect to the machine in question via RDP on 3389 on your LAN? It very well could be the firewall in WIndows 7 blocking RDP for some profile. One other thing I could think of is you need an account with a password in order to use remote desktop. Password-less accounts cant use RDP.

In regard to using nmap to scan your network, the best way to do this is to go to some coffee shop with free wifi and preform the scan on your external IP address. Nmap will produce a lot of false positives if you scan your external IP from the LAN it is connected to.

share|improve this answer
    
no need to include the authorisation/authentication into the problem. This only brings confusion as it is not connected with the OP problem in any way. RDP firstly establishes connection and with active connection you are able to provide username and password. Error message will be totaly different in case of bad password / non existent user id. Here we have a case of missing connection in the first place. –  mnmnc Dec 20 '12 at 22:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.