Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to build httpd 2.4.3 from source. I've compiled APR and APR-util (with openssl), but libtool is putting an empty include directory in the command, and it breaks. For example:

/usr/local/web/httpd-apr/build-1/libtool --silent --mode=link gcc -std=gnu99 -g -O2 -I              -L/usr/local/opt/openssl/lib   -o ab  ab.lo       /usr/local/web/httpd-apr-util/lib/libaprutil-1.la -lexpat -liconv /usr/local/web/httpd-apr/lib/libapr-1.la -lpthread  
i686-apple-darwin11-llvm-gcc-4.2: ab: No such file or directory
make[1]: *** [ab] Error 1
make: *** [all-recursive] Error 1

If you look at the -I flag, you'll see that it is followed by several blank spaces before -L/usr/local/opt/openssl/lib. As a result, I get the "no such file or directory" error. I've tried running libtool myself without the mysterious -I, but that doesn't work for everything. Am I missing a configuration option or something?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

It seems like the -I was from EXTRA_CFLAGS. Setting CFLAGS before running configure worked. I'm leaving this up in case anyone else runs into the same problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.