Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am working on windows 7. I have successfully added entries on my hosts file before and it worked fine.

But different website was given to me like this (Similar looking):  tomrkt.h123shb 

This entry doesn't seem to work.

What I mean by this is:

if i go to, it works.

If I go to https://tomrkt.h123shb/pkmslogout, it doesn't work.

I am not sure why that is, can you please shed me some light on this.


share|improve this question

migrated from Dec 21 '12 at 4:00

This question came from our site for professional and enthusiast programmers.

Sometimes especially with IE I notice it is necessary to restart the browser after editing the hosts file. Also, can you please clarify exactly what you mean by "it doesn't work". – Barry Kaye Dec 20 '12 at 15:52
Did you try restarting Windows? – Canadian Luke Dec 21 '12 at 4:06
Does ping tomrkt.h123shb return the IP ? – Hennes Jun 29 '13 at 22:58
What you're showing is not a valid domain name; the HOSTS file requires valid-format domain references. You'll need to find out the domain extension; many browsers assume it's ".com" and will append that without showing it to you. As Hennes says, you'd have to be able to ping it. You can also verify the connection by using "ping -a" to see what the full domain name is associated with that address. – Debra Jan 8 at 19:55

1 Answer 1

The entries might be cached you could try clearing the cache using:

ipconfig /flushdns 


nbtstat -R

with Administrator privileges

share|improve this answer
Forgot to mention. I tried that too. I flushed the DNS. No luck. – user1666952 Dec 20 '12 at 16:09
@user1666952 - Try nbtstat -R to also flush netbios cache – Cyclone Dec 20 '12 at 16:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.