Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm hoping to assign a specific local IP (ie 192.168.1.102) to a particular MAC address whenever this device connects with the Linksys wireless router. I've read that it's not recommended to turn off DHCP.

How can I accomplish this otherwise?

share|improve this question

1 Answer 1

Most routers provide a way for you to assign a particular IP address to a particular MAC. You're actually telling the router's DHCP server to just always make this particular assignment, so you don't need to turn off DHCP -- other devices you didn't specify a static assignment for will just get assigned some other address the router has available.

Also, this means that you should still configure your device to obtain an IP address via DHCP, rather than setting a static IP address.

share|improve this answer
    
can you generally describe to make the IP assignment in a linksys router? –  Hking Dev Dec 21 '12 at 5:38
    
What model is it? –  jjlin Dec 21 '12 at 5:41
    
the classic linksys WRT54G –  Hking Dev Dec 21 '12 at 5:45
1  
Unfortunately, I don't think that model supports static IP assignment via DHCP with the stock firmware. That router does, however, support many 3rd party firmwares like DD-WRT and Tomato that do have that feature. If you're not interested in flashing another firmware, you can see homecommunity.cisco.com/t5/Wireless-Routers/… for some alternative approaches. –  jjlin Dec 21 '12 at 5:52
    
I've setup IP addresses, gateways, and DNS on a specific computer according to the suggestion in the link you provided. The link didn't say where to change those settings, but i assumed it's in Wireless Network Connection Properties --> Internet Protocol Version 4(TCP/IPv4) Properties. After configuring a static IP address, the computer can surf the web for a while. But overtime, the computer doesn't have any connectivity anymore (no access to Internet, cannot connect to 192.168.1.1. It's not the router's fault because other computers using this router to surf the internet have no problem). –  Hking Dev Dec 22 '12 at 6:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.