Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have my Windows Mobile 6.1 Device connecting to my home router via PPTP VPN. I am able to RDP into a machine at home and see the screen. This will last for no more than a minute. The VPN connection will drop for no apparent reason.

Connecting to the RDP session via wifi @home works fine and never disconnects. Connecting via VPN and RDP from a regular windows machine is fine. It is something Windows Mobile and VPN related.

How can I keep my VPN connection alive when using Windows Mobile?

share|improve this question
    
Watching this one. I've never managed to keep my PPTP VPNs connected for more than a minute as well (also WinMo 6.1) –  Chris_K Oct 7 '09 at 14:51
    
Things are looking bleak, I have been scourging google all day yesterday and today. It seems like no one uses this functionality. –  Bob Oct 7 '09 at 14:52
    
Just in case it's not caused by the VPN (the router): maybe people might need to know what server you're connecting to? –  Arjan Oct 13 '09 at 11:33
    
Connecting to the RDP session via wifi @home works fine and never disconnects. Connecting via VPN and RDP from a regular windows machine is fine. It is something Windows Mobile and VPN related. –  Bob Oct 13 '09 at 12:25
    
Too many downvotes here! Good luck solving this. –  Arjan Oct 15 '09 at 21:57

4 Answers 4

It could be a keepalive issue.

RDP doesn't send traffic unless it has to, and it could be that your connection thinks nothing is happening and closing.

On the RDP server (assumes server 2003):

  1. Click Start, click Run, type gpedit.msc, and then click OK.
  2. Expand Computer Configuration, expand Administrative Templates, expand Windows Components, and then click Terminal Services.
  3. In the right pane, double-click Keep-Alive Connections.
  4. Click Enabled, and then click OK.
  5. Close Group Policy Object Editor, click OK, and then quit Active Directory Users and Computers.

http://support.microsoft.com/kb/216783

share|improve this answer
    
This is windows mobile. –  Bob Oct 13 '09 at 1:32
    
@Bob, seems to me that @seanyboy is talking about the server side settings. I guess you're not running Windows Mobile on that? –  Arjan Oct 13 '09 at 11:31
    
Connecting to the RDP session via wifi @home works fine and never disconnects. Connecting via VPN and RDP from a regular windows machine is fine. It is something Windows Mobile and VPN related. –  Bob Oct 13 '09 at 12:26
1  
If you open a VPN connection on your window mobile, and do nothing, does the VPN connection drop? Also, does it drop after exactly a minute? –  seanyboy Oct 13 '09 at 23:28

Another option...

Does the server name you try to connect to have a full stop in it?

Now there are a few things you may also want to setup if you plan on connecting to dotted (server.company) resources. By default the connection manager in Windows Mobile thinks that any dotted address is meant to be destined for the internet so it will drop the vpn connection and try to use the internet to connect to that address.

We can stop this by setting up "Exceptions". Tap Start > Settings > Connections (tab) > Connections (icon) > Advanced (tab) > Exceptions. You can use wildcards to represent an entire domain so tap "Addd new URL" and enter *.domain.yourdomainsuffix and now when you try to access a resource or terminal service to server.domain.yourdomainsuffix the vpn connection will stay connected.

From here:

http://social.microsoft.com/Forums/en-US/windowsmobilehelp/thread/6538e50e-8b55-4808-a8ea-d7c8767f3d3f

share|improve this answer
1  
Good find! To me, this seems an odd implementation of the Windows XP equivalent "Do NOT use default gateway on remote network" though. Many VPN administrators would prefer all traffic to run through the VPN, to ensure they have some extra control over that (like to avoid some trojan horse can be connected to the client computer while that same client computer is connected to the VPN). Dropping the VPN altogether is even more secure, of course, but not very usual I think. –  Arjan Oct 14 '09 at 11:19
    
This has been configured already. If this wasn't configured, I wouldn't be able to connect to the RDP session at all. –  Bob Oct 14 '09 at 12:33
    
And just to clarify, when this isn't configured you aren't able to connect to ANY VPN resources. –  Bob Oct 14 '09 at 12:34

The linux client (tsclient on ubuntu anyway) defaults to trying to reconnect every 60 seconds; ensure you don't leave one running somewhere or it will steal your RDP session, resulting in exactly the behavior you are seeing.

share|improve this answer

There is a post on expertsexchange which suggests this is probably an MTU setting. The posts there suggest setting it somewhere well below 1400.

Does that fix it for you?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.