Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As I'm pretty used to the Linux terminal, I set up a bash shell on my Windows XP command prompt by following the instructions in this article:

http://www.techsutram.com/2009/05/bash-environment-on-windows-this-is-not.html

I particularly wanted to settle for something light and compact and I get the impression that Cygwin is a pretty large distribution which I wanted to avoid.

It works really well for the most part but when trying to move a directory like this:

mv directory/another_directory .

I get:

mv: can't open directory/another_directory

I realise that this could be a distribution specific issue but if anyone has come across something similar could you please help?

It's odd because I have no problems renaming directories or moving files. Only when trying to move a directory.

Many thanks!

share|improve this question
    
what happens when you cd to the sub_dir and try mving it that way? – mcalex Dec 21 '12 at 11:51
    
I've downloaded a newer version of 'mv' and this seems to have fixed it, as the older one is dated at 1997, I assume it's a compatibility issue. Not sure what's going on underneath :) With the older one, moving the directory from its parent directory didn't work either. – Nobilis Dec 21 '12 at 12:02
    
@Nobilis Isn't a mv syntax like this: mv -t target_dir source_dir ? – mnmnc Dec 21 '12 at 12:07
    
mv version from 1997? O_o i'm surprised it worked at all. – mnmnc Dec 21 '12 at 12:10
    
@mnmnc You can use the syntax above for moving directories too, I guess the -t option has been added so that the user is certain the files will be moved, not renamed. -t isn't a possible option for this 'mv' util under Windows though. The online man page for mv has the following for it: mv [OPTION]... [-T] SOURCE DEST mv [OPTION]... SOURCE... DIRECTORY mv [OPTION]... -t DIRECTORY SOURCE... – Nobilis Dec 21 '12 at 12:12
up vote 0 down vote accepted

I fixed this problem by replacing the 'mv' application (dated at 1997) with a newer one (dated at 2001) located in the Unix utils pack discussed in the link.

Perhaps it was a compatibility issue with the newer version intended to address incompatibilities related to Windows XP (as they seem to have come out in the same year).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .