Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know this has been asked many times before, but I have not yet found a solution...

So as the title says, my computer displays the wrong screen resolution. What happened, was the power went down one day shutting down my computer, but I waited till the next day to boot it up again. When I did, my resolution was at 1600x1200. At the time I was trying Windows 8, so I tried reinstalling my ATI's drivers (cleanly of course), changing what type of monitor Windows displayed, installing drivers for my monitor, although it had worked perfectly up to that point, formatting my computer and reverting back to Windows 7, yet nothing worked.

If I try setting 1920x1080 (which is my desired resolution) via Windows, it reverts to 1920x1080 at 30Hz interlaced. If I go through CCC, I can change to the correct resolution and refresh rate, but windows won't remember it next time. Minor inconvenience, I know, but annoying nonetheless.

So, now I am using the Generic non-PnP Monitor from Windows with a set resolution from CCC.

My specs are:

OS: Windows 7 x64
Monitor: LG Flatron W2243S
Graphics: ATI Radeon HD 5870
Motherboard: MSI 890GXM-G65 (MS-7642)

Edit: I had been using 1920x1080 for quite a few years with this monitor and graphics card, so the resolution is compatible.
Edit 2: I just noticed that CCC shows my monitor as an analog CRT. Could that have anything to do with it?

share|improve this question
    
you mean 1920*1080 but that is a minor detail i guess –  TheUser1024 Dec 21 '12 at 12:19
    
Have you tried using a restore point? Please make sure all your information is 100% correct it seems like you have minor problems with the details. –  Ramhound Dec 21 '12 at 13:42
    
@TheUser1024 True that, I always confuse them! –  Charlie Dec 21 '12 at 15:09
    
@Ramhound As I said in the description, I did a clean format from windows 8 to windows 7. So a system restore/program is not the culprit. –  Charlie Dec 21 '12 at 15:09
    
@Charlie - If your monitor is not being detected correctly that woudl have everything to do with it. Have you replaced all cables? –  Ramhound Dec 21 '12 at 15:29
show 1 more comment

1 Answer

Thanks guys, I figured it out. It seems that indeed, it was the VGA cable. It must have got fried or something.

The steps I took where:

  1. Change cable.
  2. Uninstall graphic card drivers.
  3. Reboot and reinstall graphic card drivers.
  4. Voila! Ready!

So, for anyone else having a similar problem, change your cable or adapter!

share|improve this answer
    
Please mark this answer as accepted (it helps future Googlers). –  neersighted Dec 22 '12 at 1:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.