Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm searching for a suitable solution of my problem since a couple of hours.

I installed Gerrit and tried to set my auth type to HTTP. Thus, I had to adjust a http conf file similar to this:

<VirtualHost *:8080>
 ServerAdmin felix@localhost
 ServerName www.gerrit.test

   ProxyRequests Off
   ProxyVia Off
   ProxyPreserveHost On

  ErrorLog /var/log/gerrit.log
  CustomLog /var/log/gerrit.log combined

  <location /login/>
     AuthType Basic
     AuthName "Gerrit Code Review"
     Require valid-user
     AuthUserFile  /etc/httpd/passwd/gerritpass
  </location>

  ProxyPass / http://127.0.0.1:8080/
  ProxyPassReverse / http://127.0.0.1:8080/

  RewriteEngine on
  RewriteRule .* - [E=SM_USER:%{LA-U:REMOTE_USER}]
</VirtualHost> 

But I really don't know in what way my this Server is started, since there isn't any new configuration file in my /etc/apache2/conf.d folder.

Do you now where to find a set of clear instructions how to make this type of authentication possible?

Thank a lot!

share|improve this question
1  
the virtual host configuration sections go to a separate so-called "site" files, located in /etc/apache2/sites-available. They are being enabled using a2ensite command, which actually creates a symlink to /etc/apache2/sites-enabled. Place this configuration there. Anyway use the correct port number (:80) for the virt host: here you are setting <VirtualHost *:8080> which collides with your reverse proxy settings. –  SkyRaT Jan 15 '13 at 9:15
    
Thanks a lot! :) –  John Rumpel Feb 22 '13 at 13:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.