Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to diagnose a problem with a USB MIDI input device not working on WindowsXP.

I've noticed that my usbaudio.sys In /Windows/System32/Drivers/ is actually named USBAUDIO.sys. My question is - why the capitals? Other drivers are not named like this.

What options do I have for restoring this driver in case its bad? (I don't have a system restore point unfortunately).

Thank you

share|improve this question
Given that MIDI isn't an audio format, but a control format, is it not possible that you're looking at the wrong driver. What does the Device Manager have to say about your MIDI device? As to why they created the file name in all caps, that's just because they did. :) – Ian Atkin Dec 21 '12 at 17:08
Thanks, yes I'm aware that it's not audio data, but from what I can gather from google, it seems that MIDI over USB might be one of its responsibilities. Another reason I was suspicious of the caps is that I've seen the file on the web, not in caps. – UpTheCreek Dec 21 '12 at 17:17
Device manager sees two things - A USB Audio Device (which might actually be the soundcard element of the controller), and a USB Composite device (which may turn out to be the midi controller). Unfortunately Tools like MIDI-OX don't see any midi devices. – UpTheCreek Dec 21 '12 at 17:20
What's the device that you're connecting to your computer. It may be relevant. – Ian Atkin Dec 21 '12 at 17:27
It's this: There are two parts really: a USB soundcard, and a USB MIDI Input device, it's the latter that's not being recognised. – UpTheCreek Dec 21 '12 at 17:36

Depending on the driver in question, you may be able to download it (or even a newer version) from the manufacturer's web site.

That said, you have issues with a MIDI device. There are usually two avenues to get MIDI working: 1. the device comes with an installation disc, 2. the MIDI device driver is installed by Windows when it's plugged in.

There are a slew of things that may be causing a conflict. This could be something as simple as a Direct-X conflict, to another device that you've installed recently.

Windows XP also had a bug at one time whereby USB controllers may be set to switch off power as a power saving mechanism:

In the Device Manager...

  1. Double click "Universal Serial Bus Controllers"
  2. Find "USB root hub"
  3. Double click the first USB hub
  4. In the properties dialog, click the "Power Managemen" tab
  5. Uncheck "Allow computer to turn off this device to save power"

The Logitech WebCam issue requires a registry edit. A simple uninstall doesn't fix the conflict...

  1. Start regedit
  2. Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318} and delete LowerFilters and UpperFilters
  3. Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{6BDD1FC6-810F-11DO-BEC7-08002BE2092F} and delete LowerFilters
  4. Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{6BDD1FC5-810F-11DO-BEC7-08002BE2092F} and delete UpperFilters
  5. Move back to the root of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\
  6. Search for LVUSBSTA. For any place found (only in Control\Class), delete the LowerFilters item (it is the item that contain the value LVUSBSTA found)
  7. Restart the computer
share|improve this answer
Thanks Ian. I've got the manufacturer's drivers installed (tried a couple of times) (although for the MIDI component they are just using the standard windows MIDI over USB apparently). I've also already unchecked all of the USB-Root-hub power-management options in device-manager (sorry should have mentioned that) – UpTheCreek Dec 21 '12 at 17:44
The Direct-X conflict is something that I haven't investigated - do you know how I might go about that? – UpTheCreek Dec 21 '12 at 17:46
Basically, the claim was that Direct-X 9 conflicted with some MIDI drivers. The solution was to remove it or roll back to an earlier version. – Ian Atkin Dec 21 '12 at 17:49
Looks like I've got DX 9c. Thanks, something else to try then. Although I'm surprised that more people aren't seeing the problem if its that. – UpTheCreek Dec 21 '12 at 17:54
Also see my edit regarding the Logitech issue. I don't know if you did this or if you just uninstalled the driver. – Ian Atkin Dec 21 '12 at 18:04

I looked in my system folder and the ALLCAPS dlls usually have names in the 8.3 format (8 letter name, 3 letter extension), which means that they are from the DOS era. I suspect this is a leftover naming convention from then.

share|improve this answer
Thanks Jikag - Weird though, as I'm sure there was no Audio-over-USB in DOS days! – UpTheCreek Dec 21 '12 at 17:55
@UpTheCreek Actually, there were aplenty. MIDI was created in the mid-80s, so it's been around for quite some time. – Ian Atkin Dec 21 '12 at 18:05
@IanAtkin, sure MIDI is ancient, but USB only became popular in the late 90s and midi-over-usb in the last 10 years – UpTheCreek Dec 21 '12 at 20:24
Yeah, I had a MIDISport USB adapter on Windows 2000 in 1998. Sometimes, it even worked! :) – Ian Atkin Dec 21 '12 at 21:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .