Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When using Word 2011 for Mac, when I paste an image or create a new line after selecting all text and changing the language, the document will at those places change language.

This is very annoying, so is there a way to force Word to only allow one language in the document no matter what happens?

share|improve this question
    
you can create a macro which selects all document contents and changes it to the desired language. also, you can make a quick access button for it. –  Lorenzo Von Matterhorn Dec 31 '12 at 13:59
    
@Znau Is it possible to make a macro, which changes the language while keeping the current selection/caret position? ActiveDocument.Content.LanguageID = lang, seems to change the language, but it doesn't work. –  Tyilo Dec 31 '12 at 15:17
    
This actually works for me: pastebin.com/fGs7tncs –  Lorenzo Von Matterhorn Dec 31 '12 at 20:52

2 Answers 2

http://support.microsoft.com/kb/179596 - go to "Language" section. Simply remove other languages and set default the one you want. However, I think that setting the default language alone will do it.

share|improve this answer
    
@Emestas I normally write in 2 different languages, so I can't remove all the others. –  Tyilo Jan 2 '13 at 13:24

Choose your language in tab Review > language then uncheck Detect laguage automatically from the status bar.

share|improve this answer
    
I can't see that option: i.imgur.com/rwG5u.png –  Tyilo Jan 6 '13 at 21:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.