Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, I was trying to wipe my HDD on a Gateway T-1628 laptop. I was in a Fedora Linux 17 live disk and I found a command from the repository called hdparm. Here's an example similar to the tutorial I followed

The wipe command used the HDD's firmware to wipe itself. I tried to run the command to wipe the drive and the command failed with an I/O error. So, I used a regular wipe utility, which worked but took longer, and I installed Fedora on the drive.

When I went to reboot, it prompted me for a HDD password. Fine, I know the password, right? Wrong. Gateway's boot firmware only allows me to enter a password that's up to eight characters long, my password that I set from Linux was longer...

...So I popped the HDD into another computer, which was able to enter the longer password. I then unfroze the HDD (see the link above).

Finally, I popped the drive back into the laptop. Now, at this point, the drive no longer has a password on it and should boot normally. But the laptop still wanted a password! (the HDD didn't do this anymore on the other computer, only the Gateway).

So I'm thinking that my BIOS is somehow confused. How can I get the BIOS to forget that it needs a HDD password?

(one potential complication: while the HDD is installed, I can't get to the boot menu. I can only boot to CD or USB if I remove the drive)

share|improve this question
Why the downvote? Please explain? – John Dec 26 '12 at 4:15
up vote 0 down vote accepted

Ok, well Gateway's BIOS still sucks for limiting the password to eight characters, but I did fix it. First, I plugged the drive into a different computer, and I was able to boot because that BIOS did allow me to enter the complete password. Next, I tried to unlock the drive, which worked. But, back at the Gateway it still wanted a password. More digging and back to the other computer with the drive... Turns out I needed to send this command to the HDD in Fedora:

$ sudo hdparm --user-master u --security-unlock p /dev/sdx
$ sudo hdparm --user-master u --security-disable p /dev/sdx

Key here is I needed to unlock and disable security.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.