Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Windows 7 on a Lenovo T520. According to the specs, the wireless adapter is an Intel Centrino Advanced-N 6205. I downloaded and attempted to install the drivers for this and the associated software called Intel PROSet/Wireless, but apparently the driver installation failed. In device manager, the WLAN entry is still marked as missing, and the wireless adapter does not show up in the adapter list. When I use the PROSet/Wireless diagnostics tool, there are a series of tests it runs. The first one is labelled "Hardware Test" and it fails with the message "Wireless Hardware is not bound to transport driver". Any idea how to get the wireless adpater drivers to work?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Have you tried the ThinkVantage Update tool? This will scan the system and identify the needed driver(s) and has solved issues with Lenovo divers many times for me.

share|improve this answer
    
You're a life-saver! I wish I could upvote this 10 times. I spent over 5 hours yesterday researching and attempting to fix this manually to no avail, and the ThinkVantage update tool did it without issue! Right now I'm on superuser connected to the internet through my brand new wireless connection. –  Ben Lee Dec 22 '12 at 23:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.