Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having issues with a specific game regarding restrictive NAT. The game is AOE online. When I try to play online matches I get a message regarding having a restrictive NAT and can not play. I have read the following instructions: here.. I do not know if I am able to port forward specific ports as both PC's listed below are looking to play this game on the same network.

My set-up at home is as follows:

Router1 (Netopia 2247-02)

  • Connected to internet directly (ADSL)
  • IP: 192.168.1.1
  • DHCP: ON - from 192.168.1.11 to 192.168.1.25
  • UPnP: ON
  • Firewall: OFF

Router2 (Linksys WRT54g - DD-WRT v24 RC-5 (11/22/07) micro)

  • Connected to Router1 via LAN.
  • IP: 192.168.1.2
  • DHCP: OFF
  • UPnP: ON
  • Firewall: OFF

PC1

  • IP: Static - 192.168.1.10
  • Connected to Router2 via LAN.

PC2

  • IP: Dynamic - coming from Router1 - 192.168.1.20
  • Connected to Router2 via LAN.

What can I do to remove this restrictive NAT issue when I have two PC's trying to play the same game on the same network/router?

Thanks in advance.

Update

If I connect PC1 directly to Router1 and port forward to that IP address i.e. 192.168.1.10 it does work.

Network Diagram

enter image description here

share|improve this question
    
You might want to add Router2 to the DMZ in Router1, so you only have one level of NAT (is there a a reason you need NAT and DHCP on Router1?) – user55325 Dec 22 '12 at 18:15
    
I added Router2 as static NAT on Router1 (There is no DMZ option from what I can tell on that router). There is a third and fourth PC connecting to Router1 so I left DHCP on that as they aren't connecting to Router2 and have dynamic IPs. – Seany84 Dec 22 '12 at 19:29
    
What is the routing mode on Router 2? It should be bridge mode. – John Siu Jan 6 '13 at 6:43
    
Have you opened the 7 ports as described in this article? – harrymc Jan 6 '13 at 8:28
    
@JohnSiu Router2 is in bridge mode. – Seany84 Jan 6 '13 at 13:42
up vote 1 down vote accepted
+50

I think that you will need to change some ports on one of the computers so you could port-forward these changed ports to that computer. The options I see are:

  1. Use Port triggering rather than forwarding, if supported by the Netopia
  2. Use a VPN service that allows port-forwarding
  3. Change the ports for Games for Windows Live, as described in the Port override section.
    To summarize: Registry key HKEY_CURRENT_USER\Software\Classes\Software\Microsoft\XLive, new DWORD LivePortOverride with value between 5000 and 65535.

I believe that UPnP should stay enabled on your router.

share|improve this answer
    
I like the look of point 3. I have created a registry entry,LivePortOverride, on PC1 - value: 5050. What should my next steps be? Should UPnP be enabled on Router1 or Router2 or both? thanks a lot – Seany84 Jan 7 '13 at 20:12
    
I went with option 3 and changed the port it runs on my machine. This works on my machine at least as I haven't been able to do it on the other PC yet (room-mates PC). All I need to do is set it up on the other PC and it should be sorted. Thanks – Seany84 Jan 10 '13 at 2:54

Try disabling UPnP on router 2. I used a similar setup and had to disable ALL active functions of the second router to successfully do what you are doing (use the second router as an unmanaged switch).

share|improve this answer
    
Still getting a restrictive NAT message when UPNP is disabled on Router2. – Seany84 Jan 6 '13 at 5:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .