Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Latitude with windows 7. After a year of usage, the mouse clicks suddenly stopped working. It behaves like this with both the native mice, and with a USB mouse.

Left-clicks stopped working all together. Right-click sometimes work, but most of the time, it does unwanted things.

I suspect it’s some malware, so I ran AVG, SpyBot and MalwareBytes, but found nothing. I checked the mouse settings in the Control Panel applet, but I didn’t fine anything unusual.

Does anybody know what could be the problem or how to fix it?

share|improve this question
    
Does it work as expected in Safe Mode? How about if you boot to a different OS (like with a Linux LiveCD, or your Windows 7 install disk)? Did you try a System Restore? –  Ƭᴇcʜιᴇ007 Dec 22 '12 at 19:28
    
Try Combofix –  Ofiris Dec 22 '12 at 19:31
1  
sys restore didn't help. the problem occurred also in safe mode. –  golan Dec 22 '12 at 20:43
1  
Have you tried each of the USB ports on the Latitude? Also be certain that your known-good mouse works in other machines. If it is a wireless mouse, are the batteries fresh? –  Mac Dec 23 '12 at 6:20
1  
Tried all the usb ports, and tried the usb-mouse on another machine - it worked. So the problem remains. –  golan Dec 29 '12 at 4:51

2 Answers 2

System restore could be your friend. Try rolling your system back to an earlier date to see if that fixes your mouse problem.

Added: You might also try running the System File Checker.

Added: Check to see if a third-party shell extension is causing the problem. You can try disabling them using ShellExView.

Also, check whether the problem persists in safe mode. If it doesn't, then try performing a clean boot.

share|improve this answer
    
thanks for the reply. tried it. didn't work. –  golan Dec 22 '12 at 20:43
    
This didn't help, but thanks. Will be happy to hear of any other ideas. –  golan Dec 29 '12 at 4:49
    
@golan Okay, I've added a couple additional suggestions. –  Nicole Hamilton Dec 29 '12 at 7:48
    
Shellexview did show me some programs i didn't know were running. Disabled some - didn't help. The problem occurs also in safe mode. Any other recommendations before formatting are most welcome. –  golan Dec 30 '12 at 5:37

Check for wireless devices.

I had the same problem on two different computers at the same time and they had both worked fine until . . . I powered on a wireless router.

Turned the wireless part of the router off and all returned to normal mousing :-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.