Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to connect to my linux machine using and it kind of connects but the prompt is stuck here,any inputs on what is wrong here?also there was build running that is just stuck...so I tried to open a different session and see this issue,if I do a ctrl+C ,any subsequent command I run gets stuck

-bash: /usr2/gnakkala/.bashrc: No such file or directory

^C-bash: /usr/local/projects/l4linux/.bash_l4: Interrupted system call

usually i GET the following

-bash: /usr2/username/.bashrc: No such file or directory
-bash: /usr/local/projects/l4linux/.bash_l4: No such file or directory
arm-linux-gcc 3.4.4
make 3.81
ADS/RVCT 2.1
Mobilinux 4.1

arm-linux-gcc path: /pkg/asw/compilers/gnu/crosstool/arm-3.4.4/bin
make path: /pkg/gnu/make/3.81/bin
ARM compiler path: /pkg/asw/compilers/arm/RVCT2.1/RVCT/Programs/2.1/328/linux-pentium
Mobilinux path: /pkg/qct/software/montavista/4.1/mobilinux/devkit/arm/v5t_le/bin
share|improve this question

migrated from stackoverflow.com Dec 23 '12 at 0:56

This question came from our site for professional and enthusiast programmers.

    
using ... what? –  Rubens Dec 22 '12 at 23:06
    
using ssh secure CRT –  user1795998 Dec 22 '12 at 23:06
    
.bashrc is optional, not required, so I don't see why you're getting this error in the first place. –  Barmar Dec 22 '12 at 23:21
    
@barmar - I agree that its optional,I edited my original question that shows what I usually get when logged in ...any clues where it is stuck or how to debug/? –  user1795998 Dec 22 '12 at 23:31
add comment

1 Answer

If you can log into the machine using a different user, try adding a .bashrc file or change the shell (bash -> sh, for example) for your user.

sudo usermod THEUSERNAME -s /bin/sh
share|improve this answer
    
I am getting an error sudo: usermod: command not found –  user1795998 Dec 22 '12 at 23:11
    
Try sudo /usr/sbin/usermod username -s /bin/sh –  Robin Kanters Dec 22 '12 at 23:13
    
getting a new error usermod: user '/bin/sh' does not exist –  user1795998 Dec 22 '12 at 23:14
    
If you can execute sudo commands at all, why not create the .bashrc file with sudo nano /home/username/.bashrc then press Ctrl+X -> Y to save it (without contents). –  Robin Kanters Dec 22 '12 at 23:16
    
what does Ctrl+x --> y MEAN?as soon as i do Ctrl+x ..its exiting –  user1795998 Dec 22 '12 at 23:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.