Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently I find my Windows 7 laptop computer often "losing" connectivity with my Linksys wireless router. When it "loses connection" to the router, the computer doesn't have any connectivity (no access to Internet, cannot connect to the router 192.168.1.1) I put "losing" in quotes because my Internet Access menu shows that I'm "Connected" to my wireless router.

I don't think this is the router's fault because other computers using this router to surf the internet have no problem. To fix this problem on my current computer, I must run "Diagnose" which fixes the problem after "reset the wireless adapter". Or I can hit the disconnect button in my Internet Access menu then try to reconnect to the router, then I would have internet access again.

I don't want to run Diagnose every other hour, or have to lose connectivity during a file transfer or an online game. Do you know what is not configured correctly?

share|improve this question
    
So just the overall connectivity is affected in some way by your computer or does the speed fluctuate as well? –  Christopher Chipps Dec 23 '12 at 19:43
    
@ChristopherChipps Yes, the overall connectivity is affected. The speed doesn't fluctuate. When I have connectivity, I can surf at maximum speed. –  user22105 Dec 23 '12 at 19:45
add comment

1 Answer 1

up vote 2 down vote accepted

This indicates a problem with the drivers of the wireless network device on the computer. Try to reinstall the driver from your computer. If it is Windows Vista/7, your best bet is to uninstall the drivers and let Microsoft detect it. If it doesn't find any, be sure to have the original driversetup at hand.

Try method 1 described here: http://www.petri.co.il/removing-old-drivers-from-vista-and-windows7.htm

if the problem still continues after reinstalling the drivers, try another USB-port in your computer.

share|improve this answer
    
thank you! the computer has not acted up since I updated the driver today. –  user22105 Dec 24 '12 at 4:36
    
Glad I could help :) –  andyderuyter Dec 24 '12 at 9:49
    
it's still having the problem.... today i "lost" connection again =( –  user22105 Dec 24 '12 at 17:37
1  
Try another wireless adapter from one the computers that is working fine with wireless. Delete the current drivers from the 'problem' computer, unplug the wireless adapter. Install drivers from the other wireless adapter and plug in said wireless adapter. This way you can determine wether or not the problem is with the wireless adapter or a problem in Windows. Please try to update your question with your current Windows version and brand/model of the wireless adapter. Good luck. –  andyderuyter Dec 25 '12 at 8:36
    
what is a wireless adapter? and it can be unplugged? i thought our laptops use a wireless card that's embedded into the motherboard of the laptop. –  user22105 Dec 27 '12 at 21:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.