Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Asus A54C TB31 running Windows 7 fails to connect to a certain Wireless N network. To be more specific, it shows that it is connected but there is no internet access. I have tried disabling all services and all startup items, removing McAfee's protection, turning it into an Open network, and updating the drivers for the Wireless card.

I am seriously running out of things to check. This computer works on other networks (I believe N, but have no way to check right now). It claims to support b/g/n networks. I can ping other computers in my network, but I can't access the gateway directly wirelessly. Also, the ISP-provided access point/router/modem does not show that the device is connected. The ethernet card works in the same machine.

Any ideas?

share|improve this question
    
can you ping gateWay? and is your subnet mask Correct? –  Christopher Dec 23 '12 at 15:47
    
I can not ping my gateway, and I am not sure on the subnet mask. It was set to 255.255.255.0 (I think) and it is a 10.x.x.x IP addy from the ISP router/switch/modem/AP. –  0x90 Dec 26 '12 at 14:29
    
How does it work (1) with another router of another make at your place, (2) with another network adapter on your computer (normally via usb) ? –  harrymc Dec 26 '12 at 15:26
    
1. It works fine on other routers at different homes (same ISP). 2. I do not have a second network adapter to diagnose this. –  0x90 Dec 26 '12 at 15:38

2 Answers 2

up vote 1 down vote accepted

Try changing MAC address of the adapter (here's a simple program for that: http://www.klcconsulting.net/change_mac_w2k.htm ). Also, try reseting the router. Are you sure that the IP your WiFi adapter gets is not used elsewhere in the network? Try disconnecting everything, resetting the router and using only your not working WiFi adapter to connect. Lastly, try manually setting a random IP for the WiFi adapter. The fact that you can ping others in the network means that the gateway (router) is operating and taking your traffic as it should. Could it be that you are connected on the wire while trying it out?
Hope that helps.

share|improve this answer
    
Why would I change the MAC addy on the adapter? When you say reset, do you mean factory default or just a cold reboot? Unfortunately, I can not assign a static IP to the router. The really strange thing is that I can't see my device listed in the router's status page, but I clearly have an available IP address assigned by DHCP. –  0x90 Dec 26 '12 at 14:40
    
It might be that your MAC address is blocked by the router's firewall for somewhat unknown reason. It shouldn't be like that, but older routers tend to mess up with the firewall service part and turning it off usually boosts its performance and decreases the number of disconnects/lost packages. EDIT: you don't need to set a static IP for the router, because router's IP is given by ISP, not you. Instead, try setting a different static IP for the WiFi adapter than it is now using. –  Ernestas Dec 26 '12 at 14:42
    
Unfortunately, I can't test this today, but trust me you'll get an accept if this works out. More news after these messages. EDIT: Of course, I understand the DHCP comment. I meant setting the static IP from the router to the device, instead of setting the device's IP from itself. Does that make sense? Anyhow, I'll try it. –  0x90 Dec 26 '12 at 14:44

Sometimes one happens upon a combination of router/adapter that just do not work together at all.

You can play with the parameters of the router and the adapter, turning off all security and firewalls etc. But if nothing comes out of it, then you have only a few options :

  1. Update router firmware (if possible)
  2. Get a new router, preferably of another make
  3. Get a new adapter (since this is a laptop, this means a USB network adapter)

It would be interesting to know the make of your router and adapter, as well as router firmware version and adapter driver version. With that information, I might be able to think up some more options.

share|improve this answer
    
Thanks for the help. Also, what is a way I can find the adapter driver version? Can't even find a name. It's an integrated card to that board. I checked it out in the dev manager. I tried updating it using the latest from Asus, no go. –  0x90 Dec 26 '12 at 19:53
    
By the latest from Asus do you mean all the drivers found here? And is your Windows 7 32- or 64-bit? In any case, the adapter MUST show up in Device Manager. If you have difficulties locating it maybe one of these utilities can help. –  harrymc Dec 26 '12 at 20:01
    
I believe it's Win7 32 bit. and the adapter -does- show up in dev manager but it is listed as "Wireless Adapter." –  0x90 Dec 26 '12 at 20:02
    
The bitness can be seen in Control Panel/System. The driver details can be found in Dev Mgr/right-click/Properties. Please add as much details as you can find to your post (and answer all my questions). –  harrymc Dec 26 '12 at 20:06
    
I'd love to but the laptop is not with me right this moment and might not for another day or so. –  0x90 Dec 26 '12 at 20:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.