Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a HP DV6 laptop with ATI Radeon HD 6490M GPU. It came with Windows 7 preinstalled. I recently installed Windows 8 Pro onto it. The GPU(s) shown are Intel HD 3000 and ATI Radeon HD 7400 Series

How is this possible, Windows 8 detects a wrong GPU and installs the Driver also. The GPU shows a warning sign (error). I am not able to use the GPU, catalyst also doesn't recognize this GPU.

The GPU works perfect on Windows 7. I tried installing Win 7 drivers but it doesn't help much, the correct GPU is detected but it still doesn't work.

Any help is appreciated. Also I feel like no Windows 8 64bit Driver is available for this GPU.

share|improve this question
add comment

1 Answer

HP provides a guide how to enable the GPU:

  1. Install the HP Software Framework as found here.

  2. Next, uninstall all ATI/AMD software through Programs and Features.

  3. Go to www.hp.com and select Support and Drivers at the top.

  4. Select Software and Driver downloads and enter your product model or product number.

  5. Select the most recent operating system matching your installation of Windows 8's bit architecture. For example, Windows 7 64bit for Windows 8 64bit.

  6. Download the ATI graphics card driver.

  7. Run the file once it is finished downloading.

  8. Let the extraction process finish, but cancel the installation when prompted to continue it after the extraction. Take note of where this is extracted to. By default, this should be c:\swsetup\.

  9. Here, there should be a setup.exe for installing the ATI driver. Right-click this and select troubleshoot compatibility.

  10. Follow the compatibility troulbeshooter and select the suggested fixes. On one screen, there will be a test program button. Click this to begin the installation.

  11. Follow the installation and it should finish successfully.

  12. Once finished, right-click the desktop to verify the configure switchable graphics option is listed.

Try it, maybe it works for you, too.

share|improve this answer
    
Sorry, I dint update you. This dint work for me, unfortunately. –  Akshat Mittal Jan 22 '13 at 15:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.