Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

f I run the gimp and have one image open for editing and use hot keys to perform operations (e.g. Alt-I, s, 600, Alt-S), after I am done the focus moved from the editing window to the toolbox window. This means that I can not continue keystroke commands (e.g. Alt-F, A ...) as I have in previous versions, but must first use the mouse to put the focus back in the same window I was using just a moment before.

This is a new issue using Gimp 2.6 Ubuntu 12.04 ; I was able to do this without mouse-clicking in whatever version of Gimp is present in Ubuntu 10.04.

Is there a setting in Ubuntu, the window manager, or Gimp that I can change to get the old focus-preserving behavior back?

Thanks.

share|improve this question
    
This appears to be a known bug, reported in Aug 2012. I don't see solution or work around bugs.launchpad.net/ubuntu/+source/gimp/+bug/1033219 –  TJIC Dec 30 '12 at 13:49
add comment

1 Answer

Had the same annoying problem. Just found this:

http://voices.yahoo.com/ubuntu-hiding-gimp-toolbox-3449370.html

I went on the hunt for a "fix" for this annoyance, and here is how this "feature" can be turned off and allow for the toolbox to be hidden behind the image window. Open GIMP (Applications > Graphics > GIMP Image Editor). With Gimp open, From the Edit menu, select Preferences. Locate and select Windows Management from the left hand navigation. In the Window Management section you'll find "Window Manager Hints." Change both the hint for the toolbox and other docks to "Normal Window" and click OK.

You will be prompted to restart GIMP with the following message:

"You will have to restart GIMP for the following changes to take effect:

toolbox-window-hint
dock-window-hint"

Click OK. Close and reopen Gimp. The Toolbox will now be able to be hidden behind the main window.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.