Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Evince is already set as the default document viewer. Clicking on a document while in Nautilus will open Evince to view them. However, this is not the case when clicking on a document that appears in the Activities Overview. Instead, the Gnome Documents js application is launched.

share|improve this question
Which version of GNOME 3 are you using? In 3.6, Evince is what opens the document from the Activities Overview – fpmurphy1 Jan 1 '13 at 15:08

The search overview displays search results from various "search providers," where each provider is allowed one row of results. If you start typing the name of your PDF, the Documents provider is sorted above the Nautilus ("Files") provider. (I'm not sure how to change this.) If you click on the result under Files instead of under Documents, it should open in Evince instead of Documents.

You can also sudo rm /usr/share/gnome-shell/search-providers/gnome-documents-search-provider.ini if you want to get rid of the Documents provider entirely.

January 2016 Update: Nowadays you can disable the Documents search provider using the Search panel in System Settings, or move it down below the Nautilus provider. This is much nicer than manually removing an ini file.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.