Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Facing a problem while using scp to download a file from AWS EC2 instance(to which I have assigned a elastic IP),scp is ignoring the my-store folder. But when i access the ec2 instance over ssh, I can see, access the my-store folder.

This is the code I type on my local terminal.

scp -i Downloads/spree-store.pem ubuntu@23.23.195.159:/home/ubuntu/my-store /. scp: /home/ubuntu/my-store: No such file or directory

EDIT :
Main purpose of this question was to edit text files remotely over ssh, vim is by far the best option this article explains how to install vim and get it running https://help.ubuntu.com/community/VimHowto

P.S:use :e . to get vim to list all the files in the directory.

share|improve this question

1 Answer 1

For transferring directories with scp you must always use -r.

Normally though, the expected error message would tell you that my-store is not a regular file (which it clearly isn't) rather than stating that there's no such file or directory.

Also unless you really want "/" (your system root) as destination, remove the the slash before the dot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.