Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've had the unfortunate experience of somehow destroying my Windows 7 Pro installation so that I cannot even get into "SAFE MODE". The furthest that I get is before the colored swirl over the "Microsoft Windows"....then I get dropped into startup recovery.

The automated Windows startup recovery is unable to help me....So I figure ok, just reset back to an earlier checkpoint. Well I tried about three of them and none of them worked.

Then another problem started happening, the checkpoint recovery program stopped working after allowing me to select the restart poing. The RSTRUI.EXE program gave me a mem ref error.

OK, I figure it is a problem with the disk copy of the program, but try again by starting from the Windows 7 Installation DVD. I still get the mem ref error in RSTRUI.EXE.

So I'm stuck....I have backups but did not do a disk image.

chkdsk shows NO problems on the operating system disk.

Aside from a reload ... anybody have any other ideas that I might try?

share|improve this question

boot from the Windows 7 DVD or Windows Recovery Environment (F8) and run the command prompt and run chkdsk and sfc:

chkdsk C: /r /f

(replace C: with the drive where you installed Windows 7)

Maybe this helps to get Windows working again. If not, use a Live DVD (Linux or WinPE), backup all data and reinstall.

share|improve this answer
already did the problems on the disk at all. I'm making a xcopy of the disk as a final backup in the event (likely) that I'll be having to reinstall.....*sigh* – mdpc Dec 24 '12 at 7:20
is sfc able to detect damaged files? Maybe this prevents Windows from booting? – magicandre1981 Dec 24 '12 at 7:22
It never even makes it through an attempt to do a SAFE BOOT, without being snagged by the startup recovery system as it is providing the names of the files being loaded. My guess at this point is that some critical *.sys file became corrupted during the recovery process. – mdpc Dec 24 '12 at 7:35
that's why you should run sfc to repair damaged system files. – magicandre1981 Dec 24 '12 at 12:47

Well, I tried all the suggestions that I could find. All to no avail....thanks to all that gave any advice.

I think that I'm going to make an image at points where things are stable in addition to backups (which I was doing) this time. Thus I can get back to an image if all else fails.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.