Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Ubuntu 12.04 VM (in VirtualBox) has an IP of 10.0.0.67, I have deleted the lease in the DHCP server and set a reservation for 10.0.0.64.

Despite multiple restarts, turning off and on the ethernet interface multiple times, it still holds on to its lease of .67.

How can I force it to drop the .67 lease and get the one actually now in the DHCP server?

I've tried sudo dhclient but it errors with:

Rather than invoking init scripts through /etc/init.d, use the service utility, e.g. service smbd restart

Since the script you are attempting to invoke has been converted to an Upstart job, you may also use the reload(8) utility, e.g. reload smbd
share|improve this question

3 Answers 3

You can try this first of all in terminal.

/etc/init.d/networking restart

You can also try few other commands too.

sudo service network-manager restart

and for Server edition

sudo service networking restart
share|improve this answer

The DHCP client running in your VM also saves a copy of its lease, probably in /var/db/ or /var/lib/db3/. Stop the client, find the latest lease and delete it, then restart your client.

share|improve this answer
up vote 0 down vote accepted

Neither of the answers worked, so I just had to end up specifying a manual IP and setting an exclusion in the DHCP scope.

It looks like the problem was that every time the Ubuntu VM requested a lease, it was requesting the IP it had previously, despite my deleting all the entries in the /var/lib/dhcp folder. There was numerous lease bits in there but nothing seemed to change what one it got again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.