Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have had a long term problem with my Thinkpad randomly switching off the wireless. I haven't yet been able to discern any apparent pattern as to when or why it does it.

I have recently upgraded from Windows 7 to Windows 8 and the problem still persists.

To resolve it each time, I just need to Fn+F5 and then switch it back on. However, it is irritating and I was wondering if anyone else had encountered this and knew what the solution was?

share|improve this question
2  
Under Device Manager / wireless adapter Properties or any bundled software that controls the adapter, check if there's an option to turn off the device's power saving/sleep mode. –  Karan Dec 24 '12 at 20:51
    
This is helpful. I have unchecked the option to 'Allow the computer to turn off this device to save power'. I'll run with this for a few days and see how it goes. Thanks! –  harunahi Dec 26 '12 at 10:45

1 Answer 1

up vote 1 down vote accepted

This was solved (at the suggestion of @Karan) by switching off the option 'Allow the computer to turn off this device to save power' for the wireless adapter.

I didn't originally think this was the issue since the Thinkpad seemed to randomly switch it off even after no appreciable time delay (e.g. just switching between wireless networks). Nevertheless, this seems to have solved the problem.

This setting is reached by going to the device manager (Win+X , then click Device Manager) and looking for the Wireless Adapter under 'Network adapters').

Windows 8 Power Management

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.