Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A client of mine has an Asus R1F tablet running Windows XP Tablet SP3. It has an Intel 3945ABG wireless card; wired Ethernet is a Realtek something-or-other. In the past few days, it's developed an odd problem:

  • WiFi authenticates, but can't get an address via DHCP.
  • plug in wired Ethernet - both interfaces get good addresses
  • unplug cable, WiFi continues to work until shutdown.
  • Next morning, repeat process.

I've tried:

  • turning WiFi off/on (there's a slider switch)
  • disabling/re-enabling via Device Mangler
  • uninstalling and reinstalling the driver for the 3945ABG...
  • changing from Intel Pro/SET to Windows Wireless Zero Config (and back)
  • restarting the router
  • changing the static DHCP assignments at the router
  • upgrading the router firmware, just on general principles

The router/access point is pfSense 1.2.3RC1 (was 1.2.2); wireless card is Atheros-based. None of the 12 other users (5 with tablets) are having problems.

Edit:
I hate leaving questions like this hanging, but this one never really did get resolved. The employee who was using this tablet was downsized out, and was given the tablet as a consolation prize; I have no idea what happened to it afterward.

share|improve this question

4 Answers 4

It seems like you've tried a lot, so I would probably install wireshark on the laptop and log packets coming out of the wifi card whilst the ethernet cable is disconnected, i.e. monitor a failure to see what traffic there is. You should see a broadcast packet asking for a DHCP lease at the very least.

Also, what is the output of "ipconfig" when the laptop is authenticated, but with no DHCP lease.

share|improve this answer

Have you tried in Drive Manager deleting the wireless card and rebooting, for it to be rediscovered?

Sometimes this helps.

share|improve this answer

Try checking the wireless settings on the AP:

  • if the AP has a "Mixed Mode", like for B and G wireless try selecting 'G only' or just G
share|improve this answer

one thing i have noticed is if you turn on and off all the wireless services such as "Client for networks", Drive Filter" etc and restart and turn them on again this does clear the issue (on machines i have had issues with).

Although on a friends laptop, there was another option for Symnatec internet or network filtering enabled. uncheck this and every thing was ok.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.