Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Comtrend ADSL modem/router that shares a USB printer with IPP.

Windows XP connects correctly, but Windows 7 will not (as is confirmed by many frustrated discussion threads returned by search)

Wireshark shows that when Windows 7 is asked to connect to the printer, it sends:

POST /printers/hp HTTP/1.1
Cache-Control: no-cache
Connection: Close
Pragma: no-cache
Content-Type: application/soap+xml
User-Agent: WSDAPI
Content-Length: 520

This is followed by the XML Probe, and this particular router just closes the connection in response.

Windows XP however sends:

POST /printers/hp HTTP/1.1
Content-Type: application/ipp
User-Agent: Internet Print Provider
Content-Length: 125
Connection: Keep-Alive
Cache-Control: no-cache

followed by a query (I'm not familiar with the innards of IPP)

To which the Modem responds:

HTTP/1.1 200 OK

followed by a response that satisfies XP.

Is it is possible to have Windows 7 talk IPP and NOT soap+xml ?

All discussion threads I can find on this have people running around in circles, trying and trying again via the printer install wizard, when it appears that the problem is in the protocol language.

share|improve this question

migrated from Dec 24 '12 at 17:55

This question came from our site for system and network administrators.

Excellent first question. Good details and well written. Keep up the good work. – slm Dec 24 '12 at 13:46
I have since discovered more problems with the Comtrend router that make this print server practically unusable anyway, but the question remains open. Can Windows 7 be forced to use IPP? – Keith Jan 1 '13 at 20:20

For Windows 7 to be able to use IPP it has to be installed first. Open appwiz.cpl and select Turn Windows features on or off from the left side of the window. The feature you're interested in is Print and Document Services -> Internet Printing Client.

The IPP support is not present in Windows 7 Starter Edition as indicated here.

Be aware that the Spooler service has to be restarted for this feature to become active, you can either restart it manually through services.msc (follow this article) or simply restart the computer.

After the restart you can add the printer using Control Panel -> Devices and Printers -> Add printer -> Add a network, wireless or Bluetooth printer -> The printer I want isn't listed -->

share|improve this answer
Thank you mprill, however, please see the last sentence in my post. Everything you suggest is mentioned on most threads you can find on this subject, and it doesn't work. The problem is that this comtrend router/print server doesn't like Windows 7 sending the header 'Content-Type: application/soap+xml' and simply drops the connection. In fact in won't talk back to any HTTP connection unless it sees Content-Type: application/ipp – Keith Dec 25 '12 at 10:57
And no disrespect to mprill's effort, but precisely the reason why I posted on Serverfault and not on Superuser is that If anyone knows the answer to this, it's more likely to be a professional system and network administrator, rather than a computer enthusiast. I don't see why it was migrated. – Keith Dec 25 '12 at 13:50

Maybe you have found the answer in the mean time ... anway, for the record look here:

In short, the answer comes down to this: In HKEY_CURRENT_USER\Printers\Settings create a value called PreferredConnection and set it to 0.

This will (or should) cause windows to always use standard IPP to talk to your CUPS server and not the M$ RPC IPP.

share|improve this answer
Please summarize the content of external links in your answer so future users don't have to follow it to know the answer. – Wes Sayeed Sep 28 '14 at 1:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .