Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While I'm browsing the Internet, Opera always pop out a lots of from these Server certificate expired boxes. Several times it pops out a tons from them and I have to click to Approve on each of them or I can't watch the site.

Server certificate expired error

I tried to search for a solution but I can't find anything. Does somebody else has this problem too? I have it on every computer where Opera is installed. It's very annoying. Is there a way to turn this off or make it to automatically approve these windows?

share|improve this question
1  
is your computer/router time set correctly? –  Sathya Dec 25 '12 at 7:14

3 Answers 3

up vote 1 down vote accepted

I had the same problem. I reseted the date and time and it did not fix it. The problem still consist even though I did (as suggested) select the remember this selection on every certificate expired pop-up. I decided to check the date and time to ensure they were correctly reset. I realized that though the date and time were correct the year was not! I reset the year, date and time and so far so good, it appears to fix the problem. So with Windows Vista at least go to:

  1. Start->Control Panel->Date and Time.
  2. Click the change date and time tab.
  3. Change it to the correct date and time and click OK.

This should fix the security error.

share|improve this answer
1  
Yes this was the problem. About a month ago I realized the certificates are gone. I thought it was an Opera bug and they fixed it in an upgrade, but now you remembered me that my PC-s clock battery was discharged, and the time was stuck a lot-lot in the past. But once I set it to the correct date. Now it's still lates, but only a few days, and the problem didn't return. So this is the solution. –  totymedli Feb 3 '13 at 19:31

I have had the same problem you have had.....To prevent the re-occcurrence of a specific message do the following when you see it.

Select the Security Tab

It will have a checkbox option to say something like remember your selection....

Then press the Approve Button.

I suspect it is some problem with the incomplete distribution of all the base root certs with the Opera release.

share|improve this answer
    
So is this a problem with Opera itself and the certificates are actually OK?! –  w3d Dec 25 '12 at 0:41
    
Again, I believe that some of the root CERTS are missing and so it flags these certs as bad but once you approve the "bad" certs....things get better. –  mdpc Dec 25 '12 at 2:01

If you are getting a plethora of certificate errors on every website with the Certificate Authority: Digital Market Research Apps PTY LTD

  1. You need to delete the e-rewards notify program (Go to the Control Panel and uninstall it).
  2. Reboot your computer.

Now it works.

share|improve this answer
    
Your answer could do with more detail as to what the causal elements are likely to be (with links to references). Then also, in your zeal to answer, the answer is hard to read. If you could clean it up, that'd make it more readable. In particular, all the all-caps, and emotional commentary are unnecessary. –  killermist Mar 24 '13 at 18:14

protected by Community May 15 '13 at 14:26

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.