Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

From earlier this week my MacBook Pro's terminal is taking a lot of time (about 20 seconds) to see the bash prompt.

How do I reduce this time?

EDIT: While the login is in progress I tailed the system.log and saw the below output

Dec 25 09:28:49 olgunmysql kernel[0]: disk0s3: I/O error.
Dec 25 09:28:49 olgunmysql kernel[0]: 
Dec 25 09:28:49 --- last message repeated 1 time ---
Dec 25 09:28:49 olgunmysql.local login[1124]: in pam_sm_acct_mgmt(): OpenDirectory -             
Membership cache TTL set to 1800.
Dec 25 09:28:49 olgunmysql.local login[1124]: in od_record_check_pwpolicy(): retval: 0
Dec 25 09:28:49 olgunmysql.local login[1124]: in od_record_attribute_create_cfstring():  
returned 2 attributes for dsAttrTypeStandard:AuthenticationAuthority
Dec 25 09:28:49 olgunmysql.local login[1124]: USER_PROCESS: 1124 ttys001
share|improve this question
    
Do you remember what you did before that? Did you change anything in your .bash_profile or .profile? You obviously run MySQL, have you tried disabling that? –  slhck Dec 25 '12 at 8:58
    
Nope. No change performed. This is happening for about 1 week where mysql has been installed for about 3 or 4 months before. I also checked the disk disk0s3 which is the system disk. I repaired the permissions. It's kinda weird problem. –  Olgun Kaya Dec 25 '12 at 9:10
1  
The messages only show one specific point in time. Is there anything before or after that? Do the problems persist if you load another shell (e.g. zsh)? Do you get the same behavior with another user account? Tried rebooting (I sometimes forget that as well)? –  slhck Dec 25 '12 at 10:14
1  
Have you tried removing asl files or changing the login command? –  ؘؘؘؘ Dec 27 '12 at 13:26

1 Answer 1

http://apple.stackexchange.com/questions/41743/how-do-i-speed-up-new-terminal-tab-loading-time

this has solved my problem. To solve the problem : I just changed the terminal startup config to /usr/bin/bash instead of /usr/bash.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.