Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm testing windows7 on my althlon64 desktop, and my secondary/data hdd does not appear to be visible to windows. While it does appear in the device manager, the disk management console skips straight from hdd0 to cdrom0.

In device manager, in the device properties window, there is a tab called 'Volumes'. clicking on the button labelled 'populate' in this tab results in the message 'Volume information for this disk could not be found.'

The primary drive, a 250Gb Hitachi sata drive, and an older seagate 80gig pata drive function perfectly. The misbehaving drive is a 1TB seagate st1000340as. It still functions perfectly under ubuntu, and was functioning perfectly under XP till I stopped using the older OS. Its formatted with ntfs, as a single large partition.

What do I need to do to give windows 7 access to the data on this disk?

The bios does not give me any disk type options. only number of sectors/cylinders (auto). Ubuntu auto-mounts the disk, no special options or commands were needed. So does winxp.

share|improve this question
add comment

3 Answers

You definitely need for the disk management console to find it in the first place, otherwise you can't do anything with it.

What is the setting for the disk in Bios? Have you set it to mimic IDE or do you run it as a pure SATA disk? If it's the second you might have to install drivers for the SATA chip.

share|improve this answer
add comment

1st: When you look in the BIOS, does all the drive settings show up? I have found that Ubuntu has a knack accessing drives that the BIOS cannot fully identify.

2nd: What is the bios treating the drive as? When I have the bios set to use IRRT on the sata drive it cases some odd drive behavior.

The device doesn't show up in disk manager but it does show up under device manager you may have a bum driver. Right click and uninstall and restart, see if it pulls fresh drivers. Or try to update drivers, see if it pulls anything new.

3rd: When you are mounting the drive in Ubuntu are you doing anything special to get it to mount? /F or any other unusual switches to get it to mount?

share|improve this answer
add comment
up vote 0 down vote accepted

It turns out that XP had formatted the disk as a 'dynamic disk'. For whatever reason, microsoft aparantly decided to not to support dynamic disks in windows 7.

There does not appear to be a supported way of 'downgrading' a dynamic disk to an ordinary disk, I ended up taking a hex-editor to the partition table. While it worked, I have to say I was extremely nervous about the operation, and cannot recommend it to others.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.