Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm connecting to my work network via VPN using L2TP/IPSec, and I recently switched to Windows 8 64 bit from 32 bit Win 7 32 bit, and this problem doesn't exist in Win 7. The problem is that every time I disconnect from that particular VPN, my whole internet connection is lost, which can only be resolved by rebooting the PC. However,if I don't check the "use default gateway on remote network" located in the Advanced setting of the VPN, I can can connect/disconnect the VPN without losing the internet connection, but I can't access the work network via said VPN. I've tried flushdns and arp -d to no avail. And when I say I lose internet connection, I can't ping even local network. Any help would be appreciated!

share|improve this question
1  
disable/re-enable physical adapter may do it, but still ugly as hell. –  Solemnity Dec 25 '12 at 11:51
    
@Solemnity yup. I also found a "work-around" that first connect the VPN w/ "use default gateway on remote network" checked, and just before disconnecting, uncheck the option. I still need to remember to do this manual check/uncheck or I have to disable/re-enable the adapter or reboot. Also, just yank out the cable is NOT enough. What's weird is that Windows 7 or XP for that matter does not have this problem on the same network. –  david sedai Dec 25 '12 at 12:13

1 Answer 1

Some VPN clients will overwrite the default gateway while some others will just put one on top of the default gateway then when you disconnect, the VPN client will wipe both of the default gateway, in other words, your routing table isn't getting it's default gateway reset to the IP of your router after VPN tears down it's interface or you may have a routing conflict means the IP range you are connecting from, and an IP range you access through the VPN network, are the same.

you can either change the IP range your VPN connection uses (if you are the server administrator), or change the IP range your computer is connecting from. For example, if both your home network and destination network (which you are connecting to via VPN) use a range of 192.168.1.x, try changing your home network to 192.168.1.x.

You might also have a damaged winsock, repair it, and maybe then you will have to rebuild the VPN connection. the netsh command can rebuild the Winsock catalog. Open the command prompt and type:

netsh winsock reset

Hope it could help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.