Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Because I use Emacs with evil-mode, I often type Esc (to enter normal mode) and then some other character, like k or j. Sometimes when I hit these two keys quickly enough, it gets read as M-k or M-j instead, which does something unexpected like delete a paragraph. How can I force these sequences to be interpreted as two separate keystrokes, Esc k, all the time?

I tried (global-unset-key (kbd "M-k")) but this seems to disable all keybindings starting with Meta.

I do have a working Meta key, so I would be okay with completely disabling the Esc-prefix way of type Meta.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.