Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Windows 7 Home Premium 64-Bit installation where Windows Update has stopped working for no apparent reason.

6 new important updates are listed as available. No matter whether I try to install all of them or just a subset, it always goes like so:

  1. Updates are being downloaded.
  2. One update after the other is reported as being installed. ("Update x of n is being installed ...")
  3. After the last update has been "installed", the Windows Update icon turns red and it is stated that none of the updates were installed. (I.e. if I tried to install 6 updates, it says "6 updates failed to install.". An error code of 80071A91 is reported.

When googling for this error code, I found advice to delete files in %windir%\system32\config\txr and %windir%\system32\SMI\Store\Machine. Unfortunately, this didn't help.

What can I do? Any log file I can check?

share|improve this question
up vote 2 down vote accepted

How-to reset the File System Resource Manager if you receive error 0x80071A91

  1. Click Start click All Programs click Accessories, right-click Command Prompt, and select Run as administrator.
  2. In the Command Prompt window you will need to type the following: fsutil resource setautoreset true C:\ and press ENTER

  3. Note: You will need to replace the C:\ with the drive letter that Windows 7 is installed on.

  4. Restart your computer, and then attempt to install the failed update(s).

As always you can try the Microsoft FixIt Tool.

share|improve this answer
    
I already tried that numerous times, to not effect. – tajmahal Dec 25 '12 at 21:44
    
Check updated post – James Young Dec 25 '12 at 21:46
    
I tried this FixIt tool. It didn't work either. It said it fixed it, but it didn't. – tajmahal Dec 25 '12 at 21:46
    
Read this, sevenforums.com/windows-updates-activation/… – James Young Dec 25 '12 at 21:48
1  
Doing a repair install (upgrade install) actually fixed the problem. I would have wished for a method less brutal to work, but that was the only measure that helped. I'll mark this answer as accepted because the discussion with @James Young (in chat) lead me to finally perform a repair install. Thanks again! – tajmahal Dec 27 '12 at 14:45

Try installing them one at a time, starting with the oldest (lowest numbered). Sometimes updates can conflict, both trying to update the same files, causing them to fail.

share|improve this answer
    
I also tried that. Did not work. – tajmahal Dec 25 '12 at 21:44
    
Did you reboot after each one (even if it didn't ask)? – Nicole Hamilton Dec 25 '12 at 21:57
    
I tried both with and without rebooting. It didn't want to install a single one of them. I guess I have rebooted this machine aprox. 50 times today while trying to figure out the problem :-) – tajmahal Dec 25 '12 at 22:10

Another possible strategy is suggested by dockster in sevenforums:

1) Turn Windows Features On/Off --> Uncheck .Net Framework 3.5
2) Run Windows Update Reset Tool (Fix it) [Check "Aggressive Mode"] Article
3) Run .Net Cleanup Tool Article
4) In an elevated command prompt, execute (Article):

   1. Bring up an elevated (Administrator) command prompt
   2. Execute the following commands sequentially:
      a. fsutil resource setautoreset true c:\
      b. cd %windir%\system32\config\txr 
      c. attrib -r -s -h *
      d. del *
   3.Type: Cd c:\windows\System32\SMI\Store\Machine
     Type: Attrib –a –h –s *.TM*
     Type: Del *.TM*
     *** You may get access denied errors -- its ok for now ***

5) Restart in Safe Mode with Command Prompt. Redo the steps above in BOLD. Some files still will not delete. That's fine.
6) Restart in Normal Mode - run windows update with success.
share|improve this answer
    
I have already done that, to no effect. – tajmahal Dec 25 '12 at 22:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .