Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with local area connection on Windows 7 64bit. I have laptop dell n5110 and Realtek PCIe FE family Controller installed as driver for my Ethernet controller on it. But I am getting error and I can't go trough network identification. When I run this Windows diagnostic tool it says, that my local area network adaptor has no valid configuration of IP protocol. But in IP protocol settings I have set that IP address is obtained automatically.

I have also two different laptops connected by Ethernet cable to my router and the connection works (and of course o tried to switch cables). So, I suspect that this Realtek driver is not compatible with my router (DLink DI-524) and there is no other driver I was able to find for dell n5110 laptop.

share|improve this question

migrated from Dec 25 '12 at 22:05

This question came from our site for professional and enthusiast programmers.

Network interface drivers don't have to be compatible with the devices on the other end of the wire. So your suspicion cannot be correct. Does the port light on the router light up when you connect it to the laptop? – David Schwartz Dec 25 '12 at 19:56
I second that. Try to download the latest driver for the interface either from the dell homepage, or google to find the realtek driver and update it. You could also try to uninstall the device from device manager and reboot - the OS will automatically assign a default generic NIC driver, that should work. If it doesn't just install the driver you've downloaded. Also you can make a snapshot of the adapter settings and post it here so we can see how it looks like. – vlex Dec 25 '12 at 19:59
yes it does light. And vlex I have already tried all of that, but which settings would be useful? – Marek Lani Dec 25 '12 at 20:04

You must log in to answer this question.