Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My goal is to wake up my pc. I have connected my raspberrypi directly through lan to my pc. I have installed etherwake and wakeonlan, and both commands failed..

Well actually it doesnt really failed, contrary it said it was succeed but my pc was still off and sleepy!

How I found the mac address of my pc: http://cache.gyazo.com/ce1480e30cb3462457e7049954dd2e8b.png?1356476206 Als recheched with: http://cache.gyazo.com/2ce9d0666e2e3f3e0eb90cf45b8e9008.png?1356476324

I tried those two commands:

 sudo wakeonlan <my mac address>

outputs:

 Sending magic packet to 255.255.255.255:9 with 00:25:xx:xx:xx:xx
 and I get my console back (without anything happens).

and

 sudo etherwake <my mac address>

didnt worked. Got my console back without any warnings/succeed or something else.

Then I tried this command

sudo etherwake <my mac address> -D

Output:

 The target station address is 0:25:xx:xx:xx:xx.
 Packet is ff ff ff ff ff ff 00 25 xx xx xx xx 08 etc. etc.
 Sendto worked ! 116

Can someone help me?

This is my motherboard: asrock-z68-extreme4-gen3

owh, and yes! boot from onboard lan is enabled!! I checked this like 10 times for now.

share|improve this question

migrated from stackoverflow.com Dec 25 '12 at 23:36

This question came from our site for professional and enthusiast programmers.

1  
Stack Overflow is for programming questions. Try Super User (or Raspberry Pi, maybe). –  minitech Dec 25 '12 at 23:14
1  
@minitech: wouldn't this be a Unix & Linux question? It seems more focused on the PC end, rather than the pi itself. –  David Thomas Dec 25 '12 at 23:15
    
It's still more of a "computer setup" question than a programming question. I'd check that WakeOnLan is configured for the PC and THAT network card [and that the MAC address is right of course] –  Mats Petersson Dec 25 '12 at 23:20
    
@DavidThomas: Could be, I just said "maybe" because that could be where the problem is. And Super User seems to cover all of that. But U&L works too :) –  minitech Dec 25 '12 at 23:30
    
I tried this years ago. I recall it using UDP but no worries re router and ports with that 'cos you're within your LAN anyway. Have you enabled WakeOnLAN in your BIOS? –  barlop Dec 25 '12 at 23:42

1 Answer 1

Once you've got WOL enabled in the target system's BIOS, check that wake on LAN is enabled in its OS. In Linux, this can be done with following the command (on the target system):

sudo ethtool <NIC> | grep "Wake"

Where <NIC> is an interface name like eth0. The output should look something like the following:

Supports Wake-on: g
Wake-on: g

If the output for Supports Wake-on doesn't contain the letter g either your hardware or driver is incompatible. If it does contain g and if the output for Wake-on contains d but not g, you should be able to enable WOL with the following command:

sudo ethtool -s <NIC> wol g

Note that this setting doesn't survive reboots, so you'll have to stash the command (minus the sudo) someplace where it will be executed on boot such as /etc/network/interfaces (which will also persist through ifdown/ifup cycles) or /etc/rc.local.

Now you should be able to wake the system from elsewhere with the wakeonlan command.

Reference: Ubuntu Help: Wake on LAN

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.