Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 laptop, connected to my wifi network. I also have an Epson Stylus Photo PX730WD connected to the same wifi network.

Since few days (or weeks? as I don't print often), I am not able to print anything. The laptop does not find the printer anymore on the network.

When I look on the printer itself, it seems connected, the wifi report does not display any error. If I go on the administration site of my Neufbox (the internet box of my ISP), I can see three devices connected on the router (laptop, printer, iPhone). So I imagine that the printer is indeed connected to the network. However, I can't ping the printer from my laptop using its IP address.

I've tried to reinstall the drivers, to resetup the network connection on the printer, but still, the laptop does not find it, and I can't print anymore.

Note that everything works if I connect the printer with USB.

Do you have any idea to solve this problem?

Little update This printer is compatible with AirPrint, so I've tried to print something from my iPhone. But no luck, the iPhone does not find the printer on the network.

Thanks.

share|improve this question
    
I can't seem to find this model on the Epson site. How old is it? Have you tried unplugging the printer for a few minutes, then reconnected and powered it back on? –  CharlieRB Dec 26 '12 at 12:58
    
Only one year. You can find it here: epson.co.uk/gb/en/viewcon/corporatesite/products/mainunits/… –  romaintaz Dec 26 '12 at 16:05
    
Thanks. I did a search with the model number but it did not find it. Have you been through these Problem Solver steps? Try rebooting the router. –  CharlieRB Dec 26 '12 at 16:33
    
Rebooting didn't help (I've reboot the laptop, the printer, the router) –  romaintaz Dec 26 '12 at 16:37
    
Have you tried to print a network configuration sheet from the Printer's configuration menu? You are probably trying to ping the wrong IP. It is possible your printer renewed its IP address and the computer has the printer added by IP instead of hostname. –  xxl3ww Dec 26 '12 at 21:48
show 7 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.