Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I start NFS service on a server in a different city, and the setting in the /etc/exports as below:

/data/shared 10.2.6.*(rw,sync)

When I mount the NFS directory,it throws an error:

mount: ..... failed, reason given by server: Permission denied

When i change the setting in the /etc/exports on the remote server as below:


It works well.

Why i use a ip pattern, it failed? Anyone know?

share|improve this question

migrated from Dec 26 '12 at 15:53

This question came from our site for professional and enthusiast programmers.

up vote 1 down vote accepted

The * wildcard only works with (sub-)domain entries. For a range of IP addresses, you need to give NFS the subnet base address and netmask in CIDR notation. For more information, see the "Machine Name Formats" section of the exports(5) man page.

share|improve this answer
Thanks very much! – kino lucky Dec 28 '12 at 3:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .