Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a RHEL server with 4 NICS. I bound eth2 and eth3 as bond0.

However, I don't know how to unbind the two NICs, so I just deleted ifcfg-bond0. Then I entered service network restart, and after that, I'm unable to find eth3. It's not loaded at all.

I've tried to reboot my server, but it's still not working...

share|improve this question

migrated from stackoverflow.com Dec 26 '12 at 16:34

This question came from our site for professional and enthusiast programmers.

Remove MASTER=bond0 from eth2/3 and also remove, also remove alias bond0 bonding from /etc/modprobe.conf

share|improve this answer

In your ifcfg-eth2 and ifcfg-eth3 files under /etc/sysconfig/network-scripts, remove these two lines:

MASTER=bond0
SLAVE=yes

Restart your network service and everything should be ok.

Dont forget to clean up, remove any line having a bond-related configuration in your /etc/modprobe.conf

share|improve this answer

You must log in to answer this question.