Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop with Windows 8. When I touch a text area, the on-screen keyboard pops up. I have a laptop. It has a physical keyboard. I don't need that. It's annoying.

I know which process to kill in order to stop it, TabTip.exe. I can manually open Task Manager to kill it every time I restart my computer, but that's a pain.

I have 2 solutions, but I cannot implement either because TabTip.exe is an administrator file.

  1. Rename or move the file, so Windows cannot find it.

  2. Write a batch file to kill the process, and then put it in the startup folder.

I would preferably like to do option 1. It seems more efficient.

What can be done?

share|improve this question

3 Answers 3

up vote 8 down vote accepted

Something to try - disable the "Touch Keyboard and Handwriting Panel Service".

To do so: Run services.msc, and scroll down to find the "Touch Keyboard and Handwriting Panel Service". Stop it, and configure it's properties to set it's startup type to "Disabled".

share|improve this answer
    
That worked beautifully! Thank you. –  burkybang Dec 26 '12 at 20:30
1  
This answer was hard to find, and it worked. Note that the option will be grayed out if you aren't logged in as an administrator. –  Noumenon Feb 10 '13 at 10:25

If you look at the on-screen keyboard one of the keys say options. click on it and at the bottom of the screen you will see light colored text that says something like manage how on-screen is used, click on that and uncheck run at startup

share|improve this answer
    
Added benefit that this doesn't need admin-rights and can be configured to each users personal preferences. –  Tonny Oct 22 '13 at 12:52

Here is the easiest step-by-step I found online:

  • Press Win+W
  • Type "services," and press Enter
  • Scroll down to "Touch screen keyboard and handwriting panel"
  • You can either right click and "Stop" or you can double-click and change it from "Automatic" startup to "Manual."

This will of course, disable both the touch keyboard and handwriting service, so you'll lose handwriting recognition. This was totally worth it to me and has made my touch screen laptop experience much better, especially when I'm using the Full Screen Browser.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.