Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had a seperate btrfs partition for my home directory in my old ubuntu instalation. I "upgraded" the installation by installing a clean system on my ext4 partition which got formatted and mounted as /. As /home I've just reused the old partition without formatting it (it worked out on another machine the same way before, the only different thing is, that I've picked the same username).

Now I ended up with a clean home directory without any of the old files (I have backups, but maybe not all of the files). If I execute df I get:

Filesystem     1K-Blocks  Used     Available   Used%  Mountpoint
/dev/sdb6      386623488 169526740 202649500   46%    /home

Any Ideas how I can revoke all previous writes back to the installation point or if this is possible? Unfortunately I have no explicit snapshot.

share|improve this question

Did you ever just try

ls /home

It could be that the installation program made a new directory like /home/bob_1 whereas your old one was /home/bob and it's still sitting there waiting for you

share|improve this answer
nope, nothing there. I did the same thing on another machine with Ext3 and there it worked out fine. but unfortunately here it didn't work out. maybe there is a possibility to restore the old file tree – romedius Jun 10 '13 at 20:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .